93 2.3 slow crank but wont start...? - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-13-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: akron, oh
Posts: 5
93 2.3 slow crank but wont start...?

i have a 93 ranger 2.3 5sp 170k it will crank slowly but not start. i started it one morning and by the time i came back outside to goto work it was shut off and wouldnt start back up... it has spark and is getting fuel ive tried to jump it still nothing.... ive replaced the clutch safety ignition switch and also a coil pack... battery was bench tested also.

Thanks
Reply With Quote
  #2  
Old 02-13-2011
KLC's Avatar
KLC KLC is offline
RF Veteran
iTrader: (29)
 
Join Date: Nov 2007
Location: New Mexico
Posts: 13,115
You only need one thread per topic or question.
Reply With Quote
  #3  
Old 02-13-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: akron, oh
Posts: 5
sorry im just trying to find out asap and need to get to going back to work
Reply With Quote
  #4  
Old 02-13-2011
Dangerranger01's Avatar
Member
iTrader: (6)
 
Join Date: Nov 2005
Location: Boring/Corvallis, Oregon
Posts: 2,011
did you actually try a new battery? or get a jump. see if that helps any. It sounds like if its slowly cranking, you're not getting enough juice to the starter.

(i've had issues with battery's passing bench tests and not really being okay. how old is the battery?)
Reply With Quote
  #5  
Old 02-13-2011
Member
Thread Starter
 
Join Date: Feb 2011
Location: akron, oh
Posts: 5
I've tried jump box.... Also tried jumping from another vehicle I tried to pop start it... Still nothing just locked up the tires
Reply With Quote
  #6  
Old 02-24-2011
Member
 
Join Date: Feb 2011
Location: vancouver washington
Posts: 1
mine did the same thing and i replaced the starter and a new battery and now it starts up just fine
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
93 2.3 slow crank but wont start...? michaels813 General Technical & Electrical 0 02-13-2011 07:14 PM
93 2.3 slow crank but wont start...? michaels813 General Ford Ranger Discussion 0 02-13-2011 07:14 PM
RangerNDog's Slow Slow Build RangerNDog Project Logs 25 09-10-2009 04:18 AM
Crank, crank, crank xXcecinestpasXx86 General Technical & Electrical 7 05-08-2009 11:35 AM
The 3.Slow? More like my 2.9 extreme slow phreaky728 2.9L & 3.0L V6 Tech 7 03-20-2005 05:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:02 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.