Connecting Rod Broken - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-19-2008
CrazyAznEdge's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: Tampa, Orlando
Posts: 433
Connecting Rod Broken

So I had a problem starting up the truck with the theft light on and its at the dealership. The dealership said they couldnt turn on the truck to pull codes, but they suspect that the connecting rod is broken form water intrusion. But I last time I went offroading there was close to no water and ive been driving it for like 2 weeks. Stealership quoted $5,791 for a new rebuilt engine! Seems outrageous to me. So what to do now?
Reply With Quote
  #2  
Old 06-19-2008
Mark98xlt's Avatar
Member
 
Join Date: Jun 2004
Location: Parma Ohio
Posts: 13
is it locked up?

Did the check gauge or check engine light come up?

I locked my 3.0 last year due to the cam synchronizer gear self destructing
Reply With Quote
  #3  
Old 06-19-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
How does the dealer know for certain that the connecting rod is broken?
Reply With Quote
  #4  
Old 06-19-2008
CrazyAznEdge's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: Tampa, Orlando
Posts: 433
when i tried to start it, it sounded like it was locked up. and the dealer is just assuming that its the connecting rod. They said they wouldnt kno til they tore it apart. O and no lights came on that I know of besides the anti theft light.

Last edited by CrazyAznEdge; 06-19-2008 at 01:32 PM. Reason: more info
Reply With Quote
  #5  
Old 06-19-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
They can turn the engine over manually to see of its locked up.
Reply With Quote
  #6  
Old 06-19-2008
mhughes165's Avatar
Member
 
Join Date: Jun 2008
Location: Browns Mills, NJ
Posts: 194
there trying to hose u, if the anti theft light is on THATS why it wont start....

if it was a rod u woulda known with the truck running....
Reply With Quote
  #7  
Old 06-19-2008
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
They can turn it by the crank.

I doubt your connecting rod is broken...
Reply With Quote
  #8  
Old 06-19-2008
CrazyAznEdge's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: Tampa, Orlando
Posts: 433
thats what im thinkin that its not broken. Cause its been runnin strong for like 2 weeks after the meet. So I cant imagine anything that has to do with that. And its the theft light as stated by Hughes that is not allowing it to start. This dealership is retarded.
Reply With Quote
  #9  
Old 06-19-2008
t_schloesser's Avatar
Member
 
Join Date: Jun 2007
Location: Palm Beach, FL
Posts: 739
i'm determined it's an electrical short or cross somewhere (or like your said, a theft lock). i'll knock my brain at work and come up with some ideas, and call you later.
Reply With Quote
  #10  
Old 06-19-2008
mhughes165's Avatar
Member
 
Join Date: Jun 2008
Location: Browns Mills, NJ
Posts: 194
Quote:
Originally Posted by CrazyAznEdge View Post
thats what im thinkin that its not broken. Cause its been runnin strong for like 2 weeks after the meet. So I cant imagine anything that has to do with that. And its the theft light as stated by Hughes that is not allowing it to start. This dealership is retarded.
there not retarded at all, there hoping you however are.....like said, there tryin to hose u, theyd bill u for this **** and ud still have the same engine in the truck and theyd fix the anti theft light
Reply With Quote
  #11  
Old 06-19-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Go to a different stealership.
Reply With Quote
  #12  
Old 06-19-2008
CrazyAznEdge's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: Tampa, Orlando
Posts: 433
do you guys think that if I disable the factory alarm it will disable it?
Reply With Quote
  #13  
Old 06-19-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Quote:
Originally Posted by CrazyAznEdge View Post
do you guys think that if I disable the factory alarm it will disable it?
I think the PATS is on its own.
Reply With Quote
  #14  
Old 06-19-2008
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
Did you try D/C the battery?

Pulling and checking your fuses?

Maybe your key got "disabled", do you have a spare?

Try resetting the computer...thats my bet!
Reply With Quote
  #15  
Old 06-19-2008
CrazyAznEdge's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: Tampa, Orlando
Posts: 433
Quote:
Originally Posted by jrpro130 View Post
Did you try D/C the battery?

Pulling and checking your fuses?

Maybe your key got "disabled", do you have a spare?

Try resetting the computer...thats my bet!
I disconnected the battery, I checked all the fuses inside and under the hood, and I dont have a spare key so I how would I go upon getting another one? And how would i go to reset the comp.
Reply With Quote
  #16  
Old 06-19-2008
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
To reset the computer you just DC the battery for however long the owners manual says, IIRC it's like 10 or 15 mins.

I am almost thinking it's your KEY. That would make you not be able to start your truck. I know this sounds stupid but is there anyone that could have put another ford key on, or you have someone elses keys? If I take my moms key (ford explorer), it will go in, but the theft light will stay solid and it won't let me start it until my key goes near (it wouldn't turn anyway with her key).

You may just have to have them reprogram your PATS system, which I don't know much about.
Reply With Quote
  #17  
Old 06-19-2008
CrazyAznEdge's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: Tampa, Orlando
Posts: 433
it could be the key, i haven had any other key in it but maybe somehow it needs to be reprogrammed or something.
Reply With Quote
  #18  
Old 06-19-2008
04 EDGE
Unregistered User
 
Posts: n/a
if the pcm sees a pats fault the truck will at least turn over and should start for a second or two then stall

if the truck wont turn over then there is a problem.
Reply With Quote
  #19  
Old 06-19-2008
bucky919's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2006
Location: Minot, ND
Posts: 1,943
Quote:
Originally Posted by 04 EDGE View Post
if the pcm sees a pats fault the truck will at least turn over and should start for a second or two then stall

if the truck wont turn over then there is a problem.
huh when I tried in my truck with a key without the chip in it. It didn't even turn over, it did nothing lol
Reply With Quote
  #20  
Old 06-19-2008
CrazyAznEdge's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: Tampa, Orlando
Posts: 433
well there was never a loud noise when driving it b4 the truck never started.. so I really have no idea what it is now. The dealership write up was..

"C/S does not crank, anti theft light on. Tech found engine locked up, suspects engine has a broken connecting rod. Need to to tear engine down in order to know specifically."
Reply With Quote
  #21  
Old 06-19-2008
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
Go to another dealership.
Reply With Quote
  #22  
Old 06-19-2008
Mark98xlt's Avatar
Member
 
Join Date: Jun 2004
Location: Parma Ohio
Posts: 13
sounds like the engine is locked up if they cant turn it over manually, ask them to see them try to turn it manually with a breaker bark on the crankshaft.

Im still saying cam synchronizer gear
Reply With Quote
  #23  
Old 06-19-2008
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
Quote:
Originally Posted by Mark98xlt View Post
sounds like the engine is locked up if they cant turn it over manually, ask them to see them try to turn it manually with a breaker bark on the crankshaft.

Im still saying cam synchronizer gear
Def could be. But would that throw a theft light?
Reply With Quote
  #24  
Old 06-19-2008
Mark98xlt's Avatar
Member
 
Join Date: Jun 2004
Location: Parma Ohio
Posts: 13
Quote:
Originally Posted by jrpro130 View Post
Def could be. But would that throw a theft light?
I don't know it will throw a cps code along with a check engine and check gauge.

I don't have anti theft light on my 98 and I did have a cam gear self destroy with no warning causing the engine to lock up instantly with no warning once so ever.

I highly doubt a connecting rod would cause the engine to lock up and you would know if you threw a rod.

I say get the truck home tear it apart maybe get a breaker bar on that crankshaft pulley asap and see if it really is locked up.
Reply With Quote
  #25  
Old 06-19-2008
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
dang vic I wish I lived closer I can help you out. I'm doing more research on it now
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Broken Temperature Gauge = Broken Engine? TomJones General Technical & Electrical 7 12-19-2014 05:25 PM
Joined the Hydrolock Club: one cylinder filled and presumed broken connecting rod n3elz General Ford Ranger Discussion 55 05-30-2008 01:41 PM
Buggy's broken tie rod.....full roll of electrical tape, wrench, pliers....w/pics Alon Snapshots 26 04-29-2008 05:14 AM
connecting my radio to my laptop for MP3's FMD General Ford Ranger Discussion 12 02-28-2006 12:19 AM
how to: Connecting TWO JL Audio amps? Lumadar Audio & Video Tech 1 06-15-2005 06:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:09 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.