HELP..or she goes.. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-15-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
HELP..or she goes..

Well as the title reads..help or she goes..

the last like week i cant figure this out its driven me nuts it doesnt throw codes and im gonna throw it off the bridge..

When im driving period doesnt matter how fast where when it feels like the truck has hit a rev limiter and makes kinda that noise so i let off the gas and its gone does it usualy once on the way to work and once on the way home..now i really dont wanna throw an engine or tranny in it so if i cant figure out whats wrong im gonna sell her and just upgrade..by the way my foots not to the floor its like 1/8-1/4 petal just to maintain speed...

i have a 6000 sq ft shop I LOVE WORKING FOR TOYOTA haha so i can do just about anything.. so dont say oh youll need a shop or this or that..i HAVE EVERYTHING so if you suggest it i can see if thats it..

im pissed off and scared at the same time..i dont wanna put an engine or tranny in it but at the same time i love her to death..HELP please...anyone

shes got just over 65 000 miles too

PLEASE dont leave comments like get a 5.0 or somthing..i want help right now before i snap..thanks!

by the way..shes a 4.0, Auto, 4x4 Electric t-case, 4.10 rear and front

Last edited by Sonic_03; 02-15-2007 at 09:54 PM.
Reply With Quote
  #2  
Old 02-15-2007
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
If it is a manual, it may be the clutch slipping.

Irrelevant: My 88crx did the same thing, it was the clutch

Slave cylinder?

Did you read the codes with a reader (dumb question, but I'll help eliminate)

Maybe your clutch is not engaging all the way?
Reply With Quote
  #3  
Old 02-15-2007
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
change the plugs?
wires?
coil pack?

fuel filter?

unhook the batter for a short period of time? i would try this first and un hook it for 20 minutes.

those are jsut a few things i would do first.
Reply With Quote
  #4  
Old 02-15-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
PLUGs brand fricken new..like 5000miles ago
Wires BRAND friggen new 2 weeks old
coil pack..stock
fuel filter i just changed it like a month ago

battery well i can try that at work tomorrow..

shes an AUTO sorry and there has been NO codes thrown not a damn guage reads weird..its peein me off
Reply With Quote
  #5  
Old 02-15-2007
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
check and make sure the plugs are good, sometimes they jsut crap out for no reason.

and go unhook the battery asap!!
Reply With Quote
  #6  
Old 02-15-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
but why would it sound like a rev limiter? and wouldnt i throw a code for that..the whole truck damn neer shakes..

yea ill unhook the batter when i can get it in the shop..
Reply With Quote
  #7  
Old 02-15-2007
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
could be the torq converter locking up when its not suppose too.

mine does that sometimes.

unplugging the battery will reset the whole computer system maybe it was jsut a glitch.

check your tranny fluid level?
Reply With Quote
  #8  
Old 02-15-2007
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
sometimes i will just be going down the road the truck shakes jerks then dies and starts back up (on its own) and will run fine again for a while.

im pretty sure its tranny related.
Reply With Quote
  #9  
Old 02-15-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
if its tranny related..shes gone tomorrow...i work for toyo ill have them bring me in a used tacoma and get a good deal on it..i dont want the headache lol
Reply With Quote
  #10  
Old 02-15-2007
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
just take the easy route out.


lol you learn so much more if you figure out how to fix it.
Reply With Quote
  #11  
Old 02-15-2007
KARPE's Avatar
Member
 
Join Date: Apr 2005
Location: Valrico, Fl 33594
Posts: 4,748
I def agree with Zach, undue the Negative cable on the battery for a few mins so it resets the computer then let it idle for about 5 mins then take her out. It's the easiest fix for the simple things that are almost undiagnosable.
Reply With Quote
  #12  
Old 02-15-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
i know i know..but i dont wanna sink a rebuild into this....i know i can do it all myself but im not gonna do it..the cost is way to great for me instead to turn around and get a diff vehicle lol..if it comes down to it ill strip it then sell it i dont care...if i had my choise i woulnt put a damn auto in it..it would get the standard..
Reply With Quote
  #13  
Old 02-15-2007
TommyC's Avatar
Member
iTrader: (1)
 
Join Date: Jun 2006
Location: CA
Posts: 1,012
Do you have a bama tuner? Mine did exactly what you are describing after loading the bama tune.

Last edited by TommyC; 02-15-2007 at 11:04 PM.
Reply With Quote
  #14  
Old 02-15-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
....

no tuner..nothing changed to the computer at all, all stock
Reply With Quote
  #15  
Old 02-16-2007
Member
 
Join Date: Nov 2005
Location: Avon, IN
Posts: 756
my truck did this last summer... it was just a mass air sensor
Reply With Quote
  #16  
Old 02-16-2007
Machine090767's Avatar
RF Veteran
 
Join Date: May 2006
Location: Minnesota
Posts: 6,410
Quote:
Originally Posted by Sonic_03
if its tranny related..shes gone tomorrow...i work for toyo ill have them bring me in a used tacoma and get a good deal on it..i dont want the headache lol
...and the other day, my furnace went out. rather than try to fix it, i just decided to sell my house and look for another!
Reply With Quote
  #17  
Old 02-16-2007
KARPE's Avatar
Member
 
Join Date: Apr 2005
Location: Valrico, Fl 33594
Posts: 4,748
Zing!
Reply With Quote
  #18  
Old 02-16-2007
l2en's Avatar
Member
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Quote:
Originally Posted by edgeaholic (tm)
...and the other day, my furnace went out. rather than try to fix it, i just decided to sell my house and look for another!
ROFL!!!

That's def weird. My auto use to act up and Zach suggested the battery d/c technique and after 15 minutes off the terminal, I started up my truck and took it for a nice easy drive and it acted 100% better.
Reply With Quote
  #19  
Old 02-16-2007
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Quote:
Originally Posted by edgeaholic (tm)
...and the other day, my furnace went out. rather than try to fix it, i just decided to sell my house and look for another!
Like comparing apples and oranges................but it good for a laugh.
Reply With Quote
  #20  
Old 02-16-2007
LILBLUE04FX4L2's Avatar
Member
 
Join Date: Jun 2004
Location: Exit 105 New Jersey
Posts: 2,409
you work for Toyota and are going to buy a used truck?
they must pay ****
Reply With Quote
  #21  
Old 02-16-2007
Member
 
Join Date: Oct 2006
Location: Toronto
Posts: 251
well before you do anything drastic just do what the majority of these guys are suggesting. They are all pretty expensive things to do.

I had the engine done on my car recently and when i got it back when accelerating it would lose power and same when driving. I brought it back had new wires and plugs installed and it went away. Maybe the new wires are just no good. I dunno. Maybe try swapping back the old wires if you have them. See what happens.
Reply With Quote
  #22  
Old 02-16-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
old wires ate the dumpster..haha

no its not that they dont pay enough they pay plenty i just dont want a new truck ( aka tacoma) they drive like **** and are slow as *** UNLESS it has a 6 speed then its a nice ride..i dont like them im not a fan..but the older ones i do like its all personal preferance man and plus you dont know how many other bills i have..700$ a month for a new truck plus insurance jsut isnt in the game plan..

i started looking today also at getting a newer car instead just for the fact of driving to work everyday now and its 30min from home..came across the corolla XRS we have.. comes with the celica engine and 6 speed tranny..and its good on gas..sharp looking car for the money and it moves.. i dunno yet though..

the next week will tell me..
Reply With Quote
  #23  
Old 02-16-2007
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
it seems like you are already set on gettin something else...
Reply With Quote
  #24  
Old 02-16-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
yea i jsut dont know..i wanna keep her but the cost of fuel..ive been thinken about this for a bit but the 4x4 is the nice part


oh i tried the battery..guess we'll see what happens

she goes on the hoist tomorrow..and im allowed to hook our 9000$ diag tool up to it to diag it as it runs..should be sweet!
Reply With Quote
  #25  
Old 02-16-2007
coolpeoplswillis's Avatar
Member
 
Join Date: Jan 2006
Location: Toledo, OH
Posts: 350
speed sensor?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Well she's in the shop Nate97Ranger Drivetrain Tech 14 03-10-2007 07:41 AM
"Captain, I'm givin her all she's got!" Hefavitzen General Ford Ranger Discussion 25 06-11-2006 02:48 PM
She's Mine!!! Gearhead61 General Ford Ranger Discussion 55 12-06-2005 12:20 PM
She's in the shop... W1CKY General Ford Ranger Discussion 1 06-14-2004 03:01 PM
She's acting up... RuggerNate General Technical & Electrical 13 06-09-2004 09:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:24 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.