My K&N filter fell off and engine idels a little rough. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-07-2007
straightedge's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Davie, Florida
Posts: 633
My K&N filter fell off and engine idels a little rough.

Hey fellow members. Well, first off I've been noticing my engine has been ideling a little rough about 500 miles ago only when I'm at a stop light or just in park. Well, yesterday, I was going to check the oil and noticed my K&N air filter was totally off from the K&N CAI tube. I was like, oh crap. So, I tried putting it back on, but it wouldn't fit. The filter ring shrunk, so I ended up taking out the adapter, so I can work on it better.

So, I'm wondering,I know stuff has been sucked up, so is there anything that I could buy that would help clean it out with? Any suggestions would be great.

Thanks for the help

Matt
Reply With Quote
  #2  
Old 12-07-2007
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
I would change your oil for one
Reply With Quote
  #3  
Old 12-07-2007
Level I Supporter
 
Join Date: Aug 2006
Location: Durham, NC
Posts: 3,657
I wouldn't worry, the K&N is passing a lot of dirt & oil when it's attached.
Reply With Quote
  #4  
Old 12-07-2007
greygooseranger's Avatar
Member
 
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
Change your oil and seafoam the motor (that would be my suggestion)
Reply With Quote
  #5  
Old 12-07-2007
straightedge's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Davie, Florida
Posts: 633
Quote:
Originally Posted by greygooseranger
Change your oil and seafoam the motor (that would be my suggestion)
Good thing I have some seafoam left. One things for sure, I'm glad my Amsoil needs to be changed soon anyways, cause it would suck if it was pretty new.

Thanks for the reply fellow members.
Reply With Quote
  #6  
Old 12-07-2007
greygooseranger's Avatar
Member
 
Join Date: Apr 2006
Location: SE Michigan
Posts: 3,293
Yeah, good thing its ready to be changed...
Reply With Quote
  #7  
Old 12-07-2007
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Pick up some MAF sensor cleaner.That has got to be dirty by now.
Reply With Quote
  #8  
Old 12-07-2007
straightedge's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Davie, Florida
Posts: 633
well, I got some maf cleaner spray over at Napa and got Mobile 1 full scynthetic 5w-30 oil with a fram filter. First time I will be running the Mobile stuff cause Amsoil is a little $$$ right now.
Reply With Quote
  #9  
Old 12-07-2007
Level I Supporter
 
Join Date: Aug 2006
Location: Durham, NC
Posts: 3,657
Quote:
Originally Posted by straightedge
well, I got some maf cleaner spray over at Napa and got Mobile 1 full scynthetic 5w-30 oil with a fram filter. First time I will be running the Mobile stuff cause Amsoil is a little $$$ right now.
Outstanding move on the Mobil 1!!! Matter oif fact, it would have been an outstanding move with any other oil!! I would, however, exchange that Fram oil filter for a Motorcraft, or Purolator.
Reply With Quote
  #10  
Old 12-07-2007
k.blakeley's Avatar
Member
 
Join Date: Apr 2007
Location: East Texas
Posts: 2,823
my 1990 has been running K&N air filter and fram oil filter since day one....guess im screwed. Still going strong for 160K though.
Reply With Quote
  #11  
Old 12-07-2007
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
y are u changing your oil its the intake theres not oil in there
Reply With Quote
  #12  
Old 12-07-2007
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Put the air from the intake runs into the engine, where there is oil. Contaminates can get into the oil that way.
Reply With Quote
  #13  
Old 12-08-2007
Member
 
Join Date: Aug 2004
Posts: 688
Quote:
Originally Posted by Takeda
I wouldn't worry, the K&N is passing a lot of dirt & oil when it's attached.


No kidding. I would also attempt to clean, or just replace, the IAC
Reply With Quote
  #14  
Old 12-09-2007
straightedge's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Davie, Florida
Posts: 633
well, its runnig all good now. I cleaned the MAF and now when I start the truck, it idels at 1,100 rpm instead of 900 rpm, weird. First time I have ever sprayed cleaner on it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My wheel fell off last night SanityAside General Ford Ranger Discussion 26 09-25-2007 12:32 PM
It finally fell off audikid General Ford Ranger Discussion 5 06-27-2007 09:12 PM
Efan fell off. Blhde General Technical & Electrical 13 04-02-2007 10:07 PM
Exhaust pipe fell off -- so I ditched it for this n3elz General Technical & Electrical 11 01-03-2005 06:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.