No Heat!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-02-2006
Member
Thread Starter
 
Join Date: Nov 2006
Location: woodland, wa
Posts: 6
No Heat!!!!

i have a 1991 Ranger xtra cab with a 4.0- cam, headers etc. and i cant get my heater to work. The core is new, i replaced the thermostat and the fan works fine. Any suggestions?
Reply With Quote
  #2  
Old 11-02-2006
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
sounds stupid but is the control panel broke at all on the dash? happened to my moms merc once, the rod that controled the heat broke so it never moved... only idear i got right now
Reply With Quote
  #3  
Old 11-02-2006
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
Assuming the heater core hose is hooked up it just about has to be either the controler, a vacumme line, rod, the blend door actuator, or the door is stuck.

I'd first look for a rod that's off or a vacumme leak. (I'm not familiar with rangers HVAC systems)

Rich
Reply With Quote
  #4  
Old 11-02-2006
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Is the truck running at a normal temp?? Is the gauge reading hot or cold??
Reply With Quote
  #5  
Old 11-03-2006
Member
Thread Starter
 
Join Date: Nov 2006
Location: woodland, wa
Posts: 6
i put a new thermostat in monday....195 degrees
but the temp guage will sometimes fluctuate up to 230
and drop back down to 195. did i get a bad thermostat?
Reply With Quote
  #6  
Old 11-03-2006
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
More than likely your seeing air in the system.

Once the motor is fully warmed up turn the heater on full hot & do several 0-50mph WOT blasts. Do it again later as well.

The point being that the t-stat is closed 1/2 the time and just a single blast may not catch the stat open.

You could also do this in your driveway.. Drive the truck til it's fully warmed up. Then park it and set the parking brake.
Now put your hand on the top rad hose. You'll feel it get hotter / cooler over a few minutes time. When it *clearly* gets hotter the stat is opening. At this point free rev the motor suddenly. (with the heater on)

It's very UNLIKELY you have a bad stat. When a new one fails it does'nt open.

Rich
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Heat blower stopped, then started, now stopped heat works nanookc General Technical & Electrical 4 02-17-2015 02:18 PM
whats some good material for a heat shield? TippnOver New Ideas 12 12-11-2005 10:43 AM
Custom heat shield??? GrafixGuy New Ideas 7 11-10-2005 10:05 PM
Heat Removal - Help! sawred New Ideas 14 07-12-2005 11:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.