Rough Idle, out of ideas... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-08-2013
stockranger's Avatar
Member
Thread Starter
 
Join Date: Feb 2006
Location: garden grove , ca
Posts: 410
Rough Idle, out of ideas...

At around 60,000 my truck started to miss when idling. Now I am up to 104,000 and it is getting worse. My dad has a ranger with 30,000 so I can compare his 4.0 does not shake when idling. It was once every 30 seconds or so. Now it is every 5-10 seconds. Seems to drive ok, it is only when idling. Doesn't matter if it cold or hot.

So far I have tried

injectors cleaned
new fuel filter
plugs and wires
cleaned air filter

I can only think of two more things to try.

Clean the MAF sensor by spring sensor cleaner on it? I run a k&n filter since I got the truck. I also have easy 30,000 miles in 4 low. Maybe it has oil and dust on it.

Maybe the coil pack?
Reply With Quote
  #2  
Old 11-09-2013
Member
 
Join Date: Feb 2013
Location: washington,pa
Posts: 87
my truck did the same thing & I did every thing you did and more and had to take it to a garage and it was my injector on my number one plug, replaced it and runs like new.
Reply With Quote
  #3  
Old 11-09-2013
stockranger's Avatar
Member
Thread Starter
 
Join Date: Feb 2006
Location: garden grove , ca
Posts: 410
Quote:
Originally Posted by jessy james View Post
my truck did the same thing & I did every thing you did and more and had to take it to a garage and it was my injector on my number one plug, replaced it and runs like new.
About what did that cost?
Reply With Quote
  #4  
Old 11-09-2013
Member
 
Join Date: Feb 2013
Location: washington,pa
Posts: 87
the injector was $80 to do the work $120 so $200 total
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 05:06 PM
M5OD rough shift on rough roads, potholes, speed bumps Mike_92 Drivetrain Tech 0 10-28-2013 10:26 PM
1997 Mazda b2300 starting rough, running rough! bonecrusher SOHC - 2.3L & 2.5L Lima Engines 3 03-19-2011 05:04 AM
rough idle, stalls out on cold crank theboling 2.9L & 3.0L V6 Tech 7 01-18-2011 06:44 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.