Spark when taking off oil filter? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-26-2012
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Spark when taking off oil filter?

Was doing my oil change today and when I unscrewed my oil filter it made a massive spark...
Reply With Quote
  #2  
Old 03-26-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
maybe static?
Reply With Quote
  #3  
Old 03-27-2012
98rangerxlt's Avatar
Member
 
Join Date: Mar 2009
Location: Bakersfield, CA
Posts: 725
No, it's the stupid location of the oil filter on the 3.0's
Reply With Quote
  #4  
Old 03-27-2012
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Ahh so you guys seen it before?
Reply With Quote
  #5  
Old 03-27-2012
littlered's Avatar
Member
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
One time i was getting mine changed and the guy couldnt get it off so he got some pliers or something out and i think he hit the wires on the starter or something and he blew a hole in the oil filter.
Reply With Quote
  #6  
Old 03-27-2012
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,773
Have you checked around the filter area for any wiring that may be bare, broken or a loose wires ?

I looked on my 03, 3.0, EDGE and nothing, I have changed my oil a number of time and have never had a problem with sparks; watch the next oil chg will have sparks everywhere.
Reply With Quote
  #7  
Old 03-27-2012
thef9est1's Avatar
Member
 
Join Date: May 2007
Location: OLY, Washington
Posts: 536
Ya they had a bad placement on my 3.0l on my nissan pickup. I hit the starter a few times...the 4.0L on the range is way easy.
Reply With Quote
  #8  
Old 04-01-2012
ranger94's Avatar
Member
 
Join Date: Oct 2011
Location: abbotsford
Posts: 93
Quote:
Originally Posted by littlered View Post
One time i was getting mine changed and the guy couldnt get it off so he got some pliers or something out and i think he hit the wires on the starter or something and he blew a hole in the oil filter.
lol
Reply With Quote
  #9  
Old 04-01-2012
AIRBORNE_RANGER's Avatar
Member
 
Join Date: Mar 2012
Location: New Waterford N.S CDA
Posts: 92
bad ground ?.
Reply With Quote
  #10  
Old 04-02-2012
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
You deffinatly hit the starter. I did the same once when I first got the truck and changed the oil. hit it with the oil filter wrench.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oil filter w/o draining oil ranger rod 4.0L OHV & SOHC V6 Tech 6 02-13-2011 04:35 PM
BIg Problem taking off the oil filter. tjeepdrv 4.0L OHV & SOHC V6 Tech 3 05-30-2010 01:35 PM
All these questions about Synthetic oil......What about the oil filter? lifted97ranger General Ford Ranger Discussion 36 04-09-2007 02:20 PM
Taking Off the Oil pan 99ranger4x4 4.0L OHV & SOHC V6 Tech 7 09-17-2006 09:55 PM
The best oil and oil filter bmxrider379 4.0L OHV & SOHC V6 Tech 29 08-20-2006 02:10 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:14 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.