1990 ranger no power to instrument panel - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-29-2014
Member
Thread Starter
 
Join Date: Jul 2014
Location: masury
Posts: 1
1990 ranger no power to instrument panel

New member here looking for advice. I am trying to get my 1990 ranger back on the road. It is an extended cab 4x2 w the 2.9L engine. First off i have a new battery and truck was cranking, but i only had 6 volts to fuel pump. Traced the problem back to fuel relay only getting 6 volts from ignition switch. So i replaced the ignition switch and now i have no power to instrument cluster. I tried installing a new ignition cylinder, but that didnt work either. I still have head lights, dome light, all fuses fine and battery fully charged. No radio or warning lights almost like new cylinder isnt working. I can still jump solenoid and starter turns. One last thing there is a red led light flashing on the hookup for a scan tool (not sure what that is called) but almost like i am locked out from turning vehicle on. Any advice on where to start would be greatly appriciated
Reply With Quote
  #2  
Old 08-15-2015
Member
 
Join Date: Aug 2015
Location: dayton, ohio
Posts: 1
Quote:
Originally Posted by bjreed1999 View Post
New member here looking for advice. I am trying to get my 1990 ranger back on the road. It is an extended cab 4x2 w the 2.9L engine. First off i have a new battery and truck was cranking, but i only had 6 volts to fuel pump. Traced the problem back to fuel relay only getting 6 volts from ignition switch. So i replaced the ignition switch and now i have no power to instrument cluster. I tried installing a new ignition cylinder, but that didnt work either. I still have head lights, dome light, all fuses fine and battery fully charged. No radio or warning lights almost like new cylinder isnt working. I can still jump solenoid and starter turns. One last thing there is a red led light flashing on the hookup for a scan tool (not sure what that is called) but almost like i am locked out from turning vehicle on. Any advice on where to start would be greatly appriciated
Did you ever find out what was wrong?? It will help me 2! Dealership gave me my $$$ and truck back. They can't fix it...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Instrument Trim/Panel 93 Ranger XLT okcreferee General Technical & Electrical 1 02-14-2012 01:24 PM
96' Ranger - Instrument Panel Backlight Bulb Array jamjen General Technical & Electrical 0 10-20-2010 05:38 PM
Dash Lights and Instrument Panel Lights... Colors??? bdc217 General Technical & Electrical 8 07-02-2007 09:26 PM
Instrument panel lights black_edge4628 General Technical & Electrical 4 03-09-2006 01:00 PM
Instrument Panel PhilpotHunter General Technical & Electrical 1 06-15-2005 01:53 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.