1990 ranger starting problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-26-2010
Member
Thread Starter
 
Join Date: Nov 2010
Location: Farmington, MN
Posts: 5
1990 ranger starting problem

I need help with my truck, it wont start or even turn over.

About a mounth ago I had to jump it to get it to start, that same day it over heated and wont start since.

I've replaced the battery, both positive cables, negative cable, Solenoid

When I put the battery in all the lights where bright inside, then when I went to start it the solind made a tick sound and the lights turned off. when I dicontect the cables and try agian it does the same thing.

Does anyone know what this problem could be.

Thanks - Benjamix
Reply With Quote
  #2  
Old 11-26-2010
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Sounds like a bad starter? Have you tried to turn the engine over by hand?
Reply With Quote
  #3  
Old 11-26-2010
Member
Thread Starter
 
Join Date: Nov 2010
Location: Farmington, MN
Posts: 5
the starter is fine. the motor will turn over by hand
Reply With Quote
  #4  
Old 11-26-2010
Member
 
Join Date: Mar 2010
Location: fenton,michigan
Posts: 14
the part with the lights going out after the solenoid clicks confuses me. but if the starter wont physically turn to start the engine, that sounds like a bad ground through the starter. to fix that you would need to remove the starter and break down the 3 sections of it and sand each end and replace.
Reply With Quote
  #5  
Old 11-27-2010
Member
Thread Starter
 
Join Date: Nov 2010
Location: Farmington, MN
Posts: 5
I pulled out the alternator and it tested bad, I think thats what fried my battery.

Thanks for the help!
Reply With Quote
  #6  
Old 11-27-2010
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Did the truck start?
Reply With Quote
  #7  
Old 11-27-2010
Member
 
Join Date: Mar 2010
Location: fenton,michigan
Posts: 14
dont pay for a used or new starter... clean it, its free and it worked twice for me. not to mention how easy it is!
Reply With Quote
  #8  
Old 11-27-2010
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Same here man! The hardest part is holding the brushes in while putting the starter back together.
Reply With Quote
  #9  
Old 11-28-2010
Member
Thread Starter
 
Join Date: Nov 2010
Location: Farmington, MN
Posts: 5
not yet. I have to get the part monday
Reply With Quote
  #10  
Old 11-28-2010
Member
Thread Starter
 
Join Date: Nov 2010
Location: Farmington, MN
Posts: 5
I just repalced the starter not too long ago, so I'm pretty sure thats not the prob. I'll have to try cleaning on sometime.

Thanks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1990 Ranger 4WD front shifting problem doug Rooney Drivetrain Tech 0 12-02-2013 03:57 AM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 11:33 AM
1990 2.3l ignition problem scoutsize SOHC - 2.3L & 2.5L Lima Engines 7 07-05-2009 02:28 PM
1990 Ford Ranger Tranny problem? jdckpdl Drivetrain Tech 0 06-12-2009 10:49 AM
1990 XLT 4WD problem TheBigFUGR General Technical & Electrical 1 12-06-2007 07:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:29 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.