2004 Ranger Remote Start--HELP - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-16-2015
Member
Thread Starter
 
Join Date: Aug 2014
Location: Binghamton, NY
Posts: 2
2004 Ranger Remote Start--HELP

Hello All, first post here. I've been working on installing a 1-way remote starter in my 2004 (XLT/4.0/4x4). I have followed directions and rewired it multiple times but never any success. Here's what I have now, maybe a fresh set of eyes will see something I don't. Also, as of last night, something shorted out at the ignition harness (i saw the spark) and now neither the R/S module nor the Bypass Module will get any power. Multimeter shows 12V and when I test voltage on the purple starter wire the voltage just keeps increasing indefinitely. Also, it appears that the key in ignition chime isn't working following aforementioned spark.

Remote Starter:

Viper 4105V 1-Way Remote Start System

http://www.amazon.com/Viper-4105V-1-...APAC8M24PKX7A9

Immobilizer/PATS Bypass Module:

XPRESSKIT Databus All Interface Module

http://www.bestbuy.com/site/xpresski...&skuId=4000003

All connections are soldered

Bypass module was flashed with most recent firmware

Used multimeter to test all wires before and after connection.

I will list all connections below. I have also attached pictures of a diagram I drew to help assembly everything. Please feel free to ask questions.

-[REMOTE STARTER MODULE]-

Main Harness, 9-pin connector:
1- LIGHT GREEN BLACK--FACTORY ALARM DISARM--not used
2- GREEN/WHITE--FACTORY ALARM REARM-- not used
3- YELLOW--IGNITION OUT (TO ALARM)-- not used
4- WHITE/BLUE--ACTIVATION INPUT-- not used
5- ORANGE--GROUND WHEN LOCKED/ANTI-GRIND-- not used
6- BROWN--HORN OUTPUT-- yellow/lt. green at steering column
7- RED/WHITE--TRUNK RELEASE OUTPUT-- not used
8- BLACK--GROUND-- grounded to frame
9- WHITE--(+/-) LIGHT FLASH OUTPUT-- not used

Door Lock, 3-pin connector:
1- BLUE--UNLOCK--pink/green at SJB
2- EMPTY--NOT USED
3- GREEN--LOCK-- yellow/orange at SJB

Remote start, 6-pin connector:
1- PINK--PRIMARY IGNITION-- green/black at ignition harness
2- PURPLE--STARTER-- red/light blue at ignition harness
3- ORANGE--ACCESSORY-- yellow/grey at ignituion harness
4- *RED--12V-- yellow at ignition harness
5- PINK/WHITE--SECOND IGNITION/ACCESSORY--green/black at ignition harness
6- *RED--12V-- yellow at ignition harness
* Pin-4 & Pin-6 (both RED) spliced together into yellow at ignition harness

Satellite harness, 4-pin connector
*NOT USED*

Remote Start Harness, 5-pin connector:
1- BLACK/WHITE--NEUTRAL SAFETY SWITCH--tan/red at BJB, on starter relay, pin-85
2- VIOLET/WHITE--TACHOMETER--tan/yellow behind instrument cluster
3- BROWN--BRAKE SHUTDOWN--lt green at brake pedal switch
4- GREY--HOOD PIN SWITCH SHUTDOWN--grounded
5- BLUE/WHITE--2ND STATUS--not used

-[DBALL2 BYPASS MODULE]-

BLUE, 14-PIN:
10- ORANGE/RED--RAP OFF--driver door trigger (yellow/black) @ SJB
11- YELLOW/RED--RAP OFF--driver door trigger (yellow/black) @ SJB
*YELLOW/BLACK DRIVER DOOR TRIGGER CUT BETWEEN TWO SPLICES*

RED, 12-PIN:
10- YELLOW/BLACK--TX--spliced into white/lt green (PATS) at PCM
11- ORANGE/BLACK--RX--spliced into orange/grey (PATS) at PCM

BLACK, 10-PIN:
9- PINK(+)--IGNITION INPUT--spliced into pink primary ignition wire at 6-pin harness on R/S

WHITE, 4-PIN:
*D2D HARNESS CONNECTED TO R/S*

I have probably spent close to 40-hours working on this install. While this is my first remote starter install, automotive electrical is not something new for me. I sincerely thought this would be easy, but boy was I wrong. i'm determined to complete this install by myself. I'm not eager to have Best Buy install it, but it's looking like that is my only option at this point.

Thank you for taking the time to read this thread and consider my situation. Any input, suggestions, comments, or advice is greatly appreciated.

Pete
Attached Thumbnails
2004 Ranger Remote Start--HELP-rs1.jpg   2004 Ranger Remote Start--HELP-rs2.jpg   2004 Ranger Remote Start--HELP-rs3.jpg   2004 Ranger Remote Start--HELP-rs4.jpg  
Reply With Quote
  #2  
Old 02-02-2015
Member
 
Join Date: Feb 2015
Location: Parma, OH
Posts: 2
Did you ever figure out your problem? I am installing a Excalibur RS-360-EDP on a 06 and the wiring all looks the same on the remote starts. A quick look at your wiring, I would question your #3 orange and your #5 pink/white. Both wires are not required on a basic remote start. The orange is an accessory wire used for a circuit like climate control. The pink/white #2 ignition is a programmable 12v output wire. I think the pink/white might be your problem. Start by checking all your fuses it sounds like you hooked up two output wires together.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help identifying remote start system MotoHead68 General Technical & Electrical 1 03-05-2014 09:39 PM
1994 Ranger XLT remote start questions CallMeColt General Technical & Electrical 4 01-17-2012 05:06 PM
Need Help With Remote Start truckin420 General Technical & Electrical 1 04-21-2009 08:13 PM
remote start help ToughFord General Technical & Electrical 3 01-30-2007 11:34 AM
help my remote start! 03RangerInROC General Technical & Electrical 11 03-11-2006 11:44 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:09 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.