2007 Ranger-no heat/AC blows cold-eventually/temp gauge - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-17-2015
Member
Thread Starter
 
Join Date: Sep 2015
Location: orange park fl
Posts: 2
2007 Ranger-no heat/AC blows cold-eventually/temp gauge

Just purchased a 2007 ranger from my brother in law. He has done the basic maintenance and the engine runs well but there are a few issues, I'd like to take care of.

1. Temperature gauge-stuck on cold. Doesn't move at all.

2. Heater doesn't blow hot air.

3. AC does work but takes forever at times to blow cold air. Sometimes it comes right up, sometimes it takes half an hour.

4. Gas cap ring seems to be triggering the engine light. I can fiddle with it and the light will go off eventually but then comes back after I refill the tank. Gas cap is the original ranger cap.

I'd like to take a look at these issues over the weekend if anyone can point me towards where I should begin at.
Reply With Quote
  #2  
Old 09-21-2015
Member
 
Join Date: Aug 2015
Location: Pilot, VA
Posts: 10
1&2: Might just need a thermostat; these symptoms indicate the thermostat may be stuck open, especially if it is a 4-cyl. that tends to run cool.

4: Gas caps are cheap; I'd try another (new) one.

Good luck!
Regan
Reply With Quote
  #3  
Old 09-21-2015
Member
Thread Starter
 
Join Date: Sep 2015
Location: orange park fl
Posts: 2
Quote:
Originally Posted by Woodtroll View Post
1&2: Might just need a thermostat; these symptoms indicate the thermostat may be stuck open, especially if it is a 4-cyl. that tends to run cool.

4: Gas caps are cheap; I'd try another (new) one.

Good luck!
Regan
Thanks! Just to update, I pulled the blend door actuator and it wasn't turning. Replaced and now getting heat. The engine light persisted after replacing gas cap buy was just a blown fuse, replaced and that's good. Temp gauge now is doing a weird thing. If looked at like a clock, c is at 10 and h is at 2. For me the needle when the car is off is at 6 and operating puts it at the 8 position. Since the actuator change, ac now gets cool in 10 minutes or so after a cold start. Would both those still indicate a thermostat issue?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
98 ranger 2.5 engine ,a/c blows cold on max but hot on a/c and panel. Flashprice General Technical & Electrical 4 08-22-2014 04:54 AM
Blows only heat chasmay1 General Technical & Electrical 1 09-18-2013 06:48 PM
97 Ranger - Temp blows hot no matter where temperature control knob is located monon43 General Technical & Electrical 1 08-25-2013 09:49 PM
2002 Ranger; A/C & Heat Blows Air Thru Defrost Vents Only vsromero General Technical & Electrical 6 05-30-2012 04:36 AM
Air only blows through dash defrost on all settings floor,vent. Only blows wide open? cseay99 SOHC - 2.3L & 2.5L Lima Engines 4 12-08-2011 10:42 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:07 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.