Battery Light On.. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-20-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: Radcliff, KY
Posts: 10
Battery Light On..

Hello everyone,

Looking for some help here. I just bought this 1998 Ranger, and the battery light is on. The previous owner told me that it had been on for awhile she had the alternator tested and it was fine.

I put a new battery in it 3 days ago, and had the alternator tested again at Advance. All tests were good.

Battery measured 12.57 volts
Alternator measured 14.57 volts / 12.9 amps with no load and 14.52 volts / 11.4 amps with load.

The light will flicker when I rev the engine and while driving, but is on constantly at idle.

Any ideas?

Thanks!
Reply With Quote
  #2  
Old 03-20-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: Radcliff, KY
Posts: 10
anyone? hoping to get somewhere on this before monday.. :-\
Reply With Quote
  #3  
Old 03-23-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: Radcliff, KY
Posts: 10
bump,

still looking for help..
Reply With Quote
  #4  
Old 03-23-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Check all the grounds and battery cables for looseness, corrison or lots of dirt.
Reply With Quote
  #5  
Old 03-24-2010
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Check those battery terminal connections. A little corrosion between the contacts will do that. I have one of those gold plated positive terminal adapters that let you connect stereo equipment and other aux equipment on it on my 01. Under acceleration my battery light would flicker, until I cleaned the positive connection. Sprinkle a little baking soda over the connections and battery top to neutralize any battery acid or corrosive materials present. Then use a terminal cleaner (or wire brush) to clean the posts. Wipe up all the debris and clean the battery surface. Reconnect everything and that battery light won't return ( assuming your battery is in good working order as well as the alternator.)
Reply With Quote
  #6  
Old 03-24-2010
korey89's Avatar
Member
iTrader: (2)
 
Join Date: Mar 2008
Location: South, FL
Posts: 4,672
Also check to make sure that the little the little bottom gray connector with the single white wiring is plugged in. When I installed my new alt I forgot to fully press it in and it did the same thing. You can see it in this picture

012.jpg?t=1269438890
Reply With Quote
  #7  
Old 03-24-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: Radcliff, KY
Posts: 10
The battery is brand new, and I put new terminals on the positive and negative cables. No corrosion whatsoever on this battery.

Some of the other ground wires might be another story. Is there one I need to look at specifically?

I'll check that grey wire today.
Reply With Quote
  #8  
Old 03-25-2010
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
That little grey connector is your issue.

How did you measure amps? Most DMM's only do 10.
Reply With Quote
  #9  
Old 03-25-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: Radcliff, KY
Posts: 10
Thanks so much!

I push the connector in a little, and it moved about a 1/4 inch and now the problem is gone. It isn't real snug so I'm guessing it will work its way loose again. If it's not connected is the alternator not charging?

Advance Auto measured the volts and amps with their machine. It gives a printout with a graph and those were the numbers they gave me.
Reply With Quote
  #10  
Old 03-26-2010
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
If you haven't had a dead battery with the light on then its charging. A volt meter will tell you for sure.

12.5+ is good

I have a volt meter in my truck all the time.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1996 Battery light coming on, yet battery and alternator work' SariahLeah SOHC - 2.3L & 2.5L Lima Engines 2 06-04-2010 04:16 PM
battery light ABS light dim light RangerSkippyRoo General Technical & Electrical 3 05-25-2009 11:25 AM
running battery down, battery discharge from playing an amp'd system onebluemcm Audio & Video Tech 12 04-13-2007 04:48 PM
Battery Light , Alternator bad, truck stalling, wont hold charge ......... pushdeck General Technical & Electrical 5 11-09-2006 12:17 AM
Battery light rangerdan01 General Technical & Electrical 9 06-25-2006 12:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.