Check Engine: Large EVAP leak? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-22-2010
LancerRevo's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: El Paso, TX
Posts: 262
Check Engine: Large EVAP leak?

It had thrown that code off a week ago, then a couple days ago it went on again. They told me its probably my gas cap, that its not on good and all. So i replaced my key one for a regular one again. I reset the system again, and waiting to see if it comes on again. If so, what else can it be?
Reply With Quote
  #2  
Old 07-22-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
https://www.ranger-forums.com/f32/high-idle-48325/

Also check the fuel inlet tube to the tank for cracks. I've noticed quite a few posts over the past year from people with body lifts experiencing that.
Reply With Quote
  #3  
Old 07-22-2010
LancerRevo's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: El Paso, TX
Posts: 262
Ive actually been noticing when i start my truck its been idling kinda weird. Im pretty sure something like that is throwing it off. Thanks for the heads up, ill look into this and see if this will fix it.
Reply With Quote
  #4  
Old 07-22-2010
ShadowRanger08's Avatar
Member
iTrader: (3)
 
Join Date: Jan 2008
Location: Ontario, Canada
Posts: 1,694
my truck was throwing a code like that too...all I had to do was tighten the hose clamp on the filler hose and vent tube, I'd give that a shot too
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1987 2.9L - Gas Leak/Evap Canister Pirateman 2.9L & 3.0L V6 Tech 0 12-11-2012 12:32 AM
SMALL LEAK IN EVAP SYSTEM... bikkabee DOHC - 2.3L Duratec / Mazda L Engines 14 01-18-2012 05:55 PM
check engine light /// evap code and 2 lean codes 4x4ranger 4.0L OHV & SOHC V6 Tech 0 02-16-2010 07:10 AM
EVAP Leak '99 Ranger billj General Technical & Electrical 2 05-02-2009 07:24 AM
Evap system giving a Check Engine Light??? mustangdave 2.3L & 2.5L I4 Tech 4 09-12-2008 04:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:30 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.