ClockSpring replaced..still no horn..turn signals..etc. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-08-2010
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
Icon8 ClockSpring replaced..still no horn..turn signals..etc.

replaced my clockspring in my 01 ranger like i was told by alot of people likly to be the problem but it didnt make a diffrence. put it all back together and still have no horn no turn signals no cruise control no 4x4...took all back apart again double checked all my work and still nothing..im lost guys..any input would be great..pretty much ready to take it to the dealer..but dont wanna spend the dam money..
Reply With Quote
  #2  
Old 10-08-2010
drppdyllwrngr's Avatar
Member
iTrader: (4)
 
Join Date: Sep 2007
Location: wilmington, nc
Posts: 2,096
the turn signals and 4x4 don't go through the clockspring. so those sound possibly like a fuse.

i replaced my clock spring not too long ago (broken wires) and my horn still didn't work. turned out that the ground (horn mounts) wasn't any good. cleaned up the mounting area and all was good.
Reply With Quote
  #3  
Old 10-09-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
x2 on the grounding of the horn. my old horn was burnt out and when i put a new one in, it still wasnt working so i ran a ground somewhere else and it worked fine.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
what is going on getting a code for parts i replaced after i replaced another part 894banger General Ford Ranger Discussion 4 05-11-2011 09:45 PM
No horn, No turn signals, No cruise control, No 4x4 RangerXLT18 General Technical & Electrical 5 09-08-2010 04:15 PM
NO horn NO turn signals or cruise control???? RangerXLT18 General Technical & Electrical 6 04-08-2010 08:11 PM
Replaced DPFE, but it's still bucking! RentonRanger General Ford Ranger Discussion 14 01-02-2009 11:18 AM
clutch replaced still screwed?? oilersfan_39 Drivetrain Tech 5 06-27-2006 10:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.