help, won't start..... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-15-2010
Member
Thread Starter
 
Join Date: Nov 2009
Location: central maine
Posts: 11
help, won't start.....

was getting a clicking noise when trying to start. Truck has new battery. Replaced the starter relay on inside fender and it started right up. Thought that was fixed. Very next day doing the same thing again so I just finished putting in a new rebuilt starter. Still won't turn over. Seem to be getting the clicking from the starter solenoid now. Tried to start by jumping the relay, no luck.......please help

Am I corect that if it was the clutch safety switch I would not produce any clicking at all?
1997 ford ranger 3.0 engine, 150k miles
Reply With Quote
  #2  
Old 01-15-2010
My91Ranger's Avatar
Member
iTrader: (1)
 
Join Date: Apr 2007
Location: Roseville, Michigan
Posts: 2,252
Whats the voltage on the battery? I know you said its new but the solenoid clicking like you described usually tells me of a low voltage situation. And I believe you are correct that if it was the clutch safety switch it would not crank at all.
Reply With Quote
  #3  
Old 01-15-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Don't neglect the ground connections from the battery to the frame,body,and engine block.
Make sure they are clean and tight.
Reply With Quote
  #4  
Old 01-15-2010
TheStig88's Avatar
Member
iTrader: (4)
 
Join Date: Aug 2008
Location: Columbia, Missouri
Posts: 2,120
Quote:
Originally Posted by OTRtech View Post
Don't neglect the ground connections from the battery to the frame,body,and engine block.
Make sure they are clean and tight.
x2 if everything is new....check your cables, a loose connection won't allow for the amperage you need to crank it over and it has the same symptoms as a weak battery
Reply With Quote
  #5  
Old 01-15-2010
Member
Thread Starter
 
Join Date: Nov 2009
Location: central maine
Posts: 11
Found a loose wire on the positive side, purrrrs like a kitten now. Unfortunate to have had to spend $85 on a new starter, but still cheaper than bringing it to a garage.
Thanks to everyone for the prompt reply's and all your help....great site.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 08:07 AM
Very weird! Won't start, won't shut off, flashing exterior lights fletcher969 2.9L & 3.0L V6 Tech 4 01-14-2013 06:26 PM
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 10:53 AM
brakes done, need more help..won't start Bhavesh General Ford Ranger Discussion 7 10-15-2006 04:06 PM
HELP! 93 Ranger won't start Peanut85 General Technical & Electrical 13 06-14-2006 10:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.