Need help, LP lights stopped working!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-12-2010
cchsbuzz19's Avatar
Member
Thread Starter
iTrader: (5)
 
Join Date: Jul 2007
Location: North Canton, Ohio
Posts: 2,417
Need help, LP lights stopped working!!!

Got my bed fixed a couple weeks ago(crossmember rusted out), And I noticed the other night when I was checking to see if all my lights worked I noticed my License Plate lights weren't working, I replaced the bulbs in the summer and they don't look burnt, and I know they were working before they fixed the bed. All the wires look like there connected and nothing seems to be disconnected or anything i checked the fuses and that wasn't it. Any ideas????

Thanks,
Clay
Reply With Quote
  #2  
Old 03-12-2010
bjohnson238's Avatar
Member
 
Join Date: Nov 2008
Location: Muncie, IN
Posts: 732
Sounds like someone pinched/cut a wire when fixing the xmember.
Reply With Quote
  #3  
Old 03-12-2010
cchsbuzz19's Avatar
Member
Thread Starter
iTrader: (5)
 
Join Date: Jul 2007
Location: North Canton, Ohio
Posts: 2,417
That def. could be it, I guess I'll try and find where its pinched, Thanks man.
Reply With Quote
  #4  
Old 03-13-2010
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,773
Start at the LP Light, chk for 12 V.
Work toward the front until you locate the problem.
Also, while you are at it, chk for a good ground at the LP Light.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Heat blower stopped, then started, now stopped heat works nanookc General Technical & Electrical 4 02-17-2015 02:18 PM
All warning lights on -- signal lights stopped working Rob91 General Technical & Electrical 1 02-04-2012 05:27 PM
HIDS STOPPED WORKING?! need help! 9ranger8 General Technical & Electrical 7 03-18-2011 08:37 PM
Ranger brake lights stopped working when trailer was hooked up, still don't work tomz General Technical & Electrical 10 10-08-2010 05:46 PM
Pics: Sub and Amp stopped working. Need HELP! feh728 Audio & Video Tech 15 04-08-2009 08:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:19 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.