Ranger brake lights stopped working when trailer was hooked up, still don't work - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-05-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: Austin, TX
Posts: 6
Ranger brake lights stopped working when trailer was hooked up, still don't work

I have a trailer I use with other vehicles with no problem. Just got the 99 Ranger and tested hooking up the trailer to see if lights worked. (To test Ranger harness)
1. Blinker left and right - worked.
2. Tapped brake lights Ė worked.
3. Running lights Ė worked.
4. Flasher lights Ė worked.
Went back to brake lights. They donít work. Then noticed the Ranger brake lights arenít working. In short all lights work on trailer and on Ranger work except brake lights on both.

So I unplug trailer. Ranger brake lights still donít work. There is some converter on the ranger harness from a round plug to the standard, so I unplug it. Same thing. I check fuses. All fuses seem to be flash and brake together on same fuse, but all fuses that seem to relate are good. I take out the brake/flash bulb. Both filaments appear good. A brand new bulb was put in. Same thing, turn filament in the bulb works, but brake in same bulb does not.
So the brake lights worked for the tap at the very beginning on trailer and always worked on Ranger. But not anymore.
Any suggestions?

Thanks,
Tomz
Reply With Quote
  #2  
Old 10-05-2010
steveo1271's Avatar
Member
 
Join Date: Oct 2009
Location: lexington,sc
Posts: 780
there's a switch on your brake pedel, that might need to be replaced
Reply With Quote
  #3  
Old 10-06-2010
MPT MPT is offline
Member
 
Join Date: Oct 2010
Location: Blairmore
Posts: 9
Check the fuse for the brake lights in your ranger, there is a shoft somewhere in the trailor harness, be it in the truck or trailer,
Reply With Quote
  #4  
Old 10-06-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Are the tail lights on the Ranger a 2 bulb or 3 bulb setup ?
Trailers are generally always 2 filament bulbs , one for brake/turn , one for tail lamp.
You need a certain setup to run a trailer harness if you have a three bulb tail light on the truck , as one bulb is for turn signal , and a different bulb for brake light.
Reply With Quote
  #5  
Old 10-06-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
its a 99 so it would be a 3 bulb set up
Reply With Quote
  #6  
Old 10-06-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: Austin, TX
Posts: 6
Quote:
Originally Posted by steveo1271 View Post
there's a switch on your brake pedel, that might need to be replaced
Thanks steveo1271, Will look for it.
Tomz
Reply With Quote
  #7  
Old 10-06-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: Austin, TX
Posts: 6
Quote:
Originally Posted by OTRtech View Post
Are the tail lights on the Ranger a 2 bulb or 3 bulb setup ?
Trailers are generally always 2 filament bulbs , one for brake/turn , one for tail lamp.
You need a certain setup to run a trailer harness if you have a three bulb tail light on the truck , as one bulb is for turn signal , and a different bulb for brake light.
But the odd thing is now - no trailer - the Ranger still has no brake lights.
To be precise, Ranger is a three bulb set up. Top backup light, Middle bulb is 2 filament, one brake and one turn. Turn works, brake doesn't... with no trailer. Bottom bulb - running light

Tomz

Last edited by tomz; 10-06-2010 at 05:34 PM.
Reply With Quote
  #8  
Old 10-06-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: Austin, TX
Posts: 6
Quote:
Originally Posted by MPT View Post
Check the fuse for the brake lights in your ranger, there is a shoft somewhere in the trailor harness, be it in the truck or trailer,
That's one of the first things as I described in the OP above. All fuses good, and it appears that any time there is a fuse, the turn signal is on the same fuse as the brake.
And the turns lights work and the brake lights don't. Inside the same bulb. (With no trailer and no harness)

Thanks,
Tomz
Reply With Quote
  #9  
Old 10-06-2010
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Did you splice your harness or get the adapter that plugs into it?

If the parking lamps and license lamps work your ground is ok.

*EDIT*

Does the high mount brake light work?

Last edited by Blhde; 10-06-2010 at 09:20 PM.
Reply With Quote
  #10  
Old 10-07-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: Austin, TX
Posts: 6
Quote:
Originally Posted by steveo1271 View Post
there's a switch on your brake pedal, that might need to be replaced
BRAVO steveo1271!!! That switch on the brake pedal seems to be it. If I manually move that switch block (push it forward or back) the brake lights come on. But if I push the brake pedal, brake lights don't come on.

The switch seems to be attached to the middle of the pedal bar. A bolt goes through the bar, through the switch then held with a cotter pin. I understand it is a $7 part and a snap to change it, guess I will change it. You think it just needs to be replaced even though I get the brake lights when I move the switch by hand?

Thanks,
Tomz
Reply With Quote
  #11  
Old 10-08-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: Austin, TX
Posts: 6
Quote:
Originally Posted by steveo1271 View Post
there's a switch on your brake pedel, that might need to be replaced
Thanks steveo1271 - that was it.

Replaced the BOO switch on the pedal. Brake lights work, hooked up trailer, all brake lights work.

Just strange it went out the first time I hooked up the trailer.

Tomz
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake lights don't work; #10 fuse keeps blowing; abs light comes on. 93 ranger Shadowsanjimaru General Technical & Electrical 1 12-03-2013 06:27 PM
4-Pin trailer wiring stopped working. jayinwww General Technical & Electrical 5 07-23-2013 08:11 AM
Brake and Signal Lights Not Working After Hooking Up Trailer. derek89 General Technical & Electrical 2 04-18-2013 08:49 PM
All warning lights on -- signal lights stopped working Rob91 General Technical & Electrical 1 02-04-2012 05:27 PM
Light wiring help. Hooked up, not working. Fuses blowing. Masteratarms93 General Technical & Electrical 7 08-21-2010 12:37 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.