No Cruise control, No turn signals dash indicator lights on all the time. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-29-2014
Member
Thread Starter
 
Join Date: Nov 2014
Location: Richland, WA
Posts: 1
Icon5 No Cruise control, No turn signals dash indicator lights on all the time.

Hello all, I have an issue with my 2004 Ford Ranger, the ABS & Parking brake lights are on all the "time." I've changed two blown fusses it helped, but now the fuse is good and the lights are still "on." I have no signal lights or cruise "control." Any clues out there?? "Thanks." Duster1947
Reply With Quote
  #2  
Old 11-29-2014
Member
 
Join Date: Mar 2012
Location: powhatan VA
Posts: 28
not sure about cruise control. With that symptom put aside, sounds like signal flasher is bad. Any parts store should sell them, and give loction of part. Should be under dash, near steering column
Reply With Quote
  #3  
Old 11-30-2014
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by duster1947 View Post
Hello all, I have an issue with my 2004 Ford Ranger, the ABS & Parking brake lights are on all the "time." I've changed two blown fusses it helped, but now the fuse is good and the lights are still "on." I have no signal lights or cruise "control." Any clues out there?? "Thanks." Duster1947
Re-check the following fuses:

Note: check with the fuses plugged in utilizing a test light or volt meter to test both sides of the fuse to ensure power is available and the fuse is good.

#20 (10 amp hot in run) and #32 (5 amp hot at all times) located in the smart junction box (cab fuse panel).

and

#15 (30 amp) and #17 (40 amp) located in the battery junction box (under hood)

Last edited by Rev; 11-30-2014 at 02:46 PM.
Reply With Quote
  #4  
Old 12-01-2014
Bob C. of Indiana's Avatar
Member
 
Join Date: Oct 2012
Location: Central ,Indiana
Posts: 217
Try cleaning the multi-function switch on the turn signal lever. It can create several types of problems if the contacts are dirty.Good Luck!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Installed aftermarket headlights, ALL turn signals stopped working RWeidner13 General Technical & Electrical 6 02-21-2015 02:46 PM
94 ranger turn signals won't work! v6 4x2 all other lights and wipers work not fuse? kappesdeb General Technical & Electrical 0 07-17-2014 12:45 PM
No horn, No turn signals, No cruise control, No 4x4 RangerXLT18 General Technical & Electrical 5 09-08-2010 04:15 PM
NO horn NO turn signals or cruise control???? RangerXLT18 General Technical & Electrical 6 04-08-2010 08:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.