No idea what to do. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-16-2016
Member
Thread Starter
 
Join Date: Jun 2016
Location: Winnipeg
Posts: 3
Icon4 No idea what to do.

The outside marker signal lights on my 2004 Ford Ranger Edge have stopped working. Checked all the fuses twice over. Under the hood and inside the cab fuse panels. All fuses and relays are intact. Checked all the bulbs and and wiring its all functional. Turn on the lights and the marker lights run. Yet still don't signal at all. Cleaned all connections and bulbs. No idea where to go from here. On a side note the fog lights and rear license plate light does not work either. Also need the signals working properly for my sister to take the her road test. Immediate help would be greatly appreciated.
Reply With Quote
  #2  
Old 06-16-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,599
Welcome to the forum

A little confused on your wording but will try to help.

What I read is that the head lights and Parking lights all work.
The front turn signals work and the turn indicators in the dash work

What about Brake lights, that's the same wire as rear turn signals?

Rear turn signals do not work
Rear license plate light doesn't work
Fog lights do not work.


I doubt the license plate or fog lights are related to turn signals.

The rear parking lights and turn signal/brake lights all share the same ground, so if parking lights are working then Ground is good.

Check if you have a trailer wiring connector, if so check it from corrosion, could be causing issues.

The Parking lights and license plate bulbs get power from the same Brown wire and are ground by a black wire at each socket
Same black wire grounds the turn/brake bulb

Left turn/brake uses a Light green wire
Right turn/brake uses an Orange wire

If brake light don't work then most likely the Multi-function switch(turn signal stalk) is where the problem is.
Could just be a loose connection.

Front and rear turn signals use different wires out of the Multi-function switch, brake lights share the same wire with rear turn signals.

what happens when you turn on the 4 way flasher
Reply With Quote
  #3  
Old 06-16-2016
Member
Thread Starter
 
Join Date: Jun 2016
Location: Winnipeg
Posts: 3
Edit: are the side yellow marker lights even supposed to flash? @Ron the brake lights work. The grounds are all good.
Reply With Quote
  #4  
Old 06-17-2016
vista4.0's Avatar
Member
iTrader: (3)
 
Join Date: Jan 2009
Location: Beaver Falls, PA
Posts: 2,824
Corner marker light does not light up when signaling. It is a common mod here to wire the corner light to flash along with the turn signal.
Reply With Quote
  #5  
Old 06-17-2016
Member
Thread Starter
 
Join Date: Jun 2016
Location: Winnipeg
Posts: 3
Thank you @Vista4.0 I thought my step dad was wrong when he said he swore they did. I'm suprised they don't flash as factory. Either way issue resolved except for the fog lights and rear license plate lamp. The grounds are all good the wires looked good. Hazards work. Indicators in the dash are fine. Haven't check the trailer wiring that much though. Step dad says it's fine. Have to look for myself.
Reply With Quote
  #6  
Old 06-17-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,599
If brake lights work(uses same wire as rear turn signals) and front turn signals work then problem will be in the multi-function switch or its connector
If front turn doesn't work then could be Flasher.

Do the 4-ways work?
Front and rear


The license plate bulbs use the same power wire as the tail lights, the brown wire runs to rear of vehicle then splits off to all the "parking lights".
So if tail lights come on then the brown wire is OK to the rear of vehicle but going to the License plate bulbs it is broken, or local Ground is bad just for those bulbs.

Fog lights get power via 2 relays in the engine fuse box

The switch on the dash activates the power relay that sends power, from a 20amp fuse in engine fuse box, to the fog lights and the "on indicator" on the fog light switch.
So if indicator is not coming on then relay is not activating, if indicator does come on the wires to bulbs are the issue.

The second relay looks like an override, which turns off fog lights if High Beams are used.
Do your high beams work?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
shift knob idea for hurst bjv11 Drivetrain Tech 25 12-29-2011 12:27 AM
Dash Lights Idea!!!! loneranger863 Interior Semi-Tech 20 10-16-2008 12:20 AM
idea for front bumper SVT01RANGER New Ideas 16 09-17-2004 12:59 AM
idea for a lift for new truck KyRanger General Ford Ranger Discussion 2 06-19-2004 05:52 PM
Plate/Tailgate idea thelowranger New Ideas 2 06-09-2004 08:21 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:06 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.