Speedo jumping - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-07-2009
Robin Hood's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: AZ
Posts: 789
Speedo jumping

I've been having this issue for a while but it was only happening like every couple months. Now today, when I hit my brakes pretty hard the speedo wont stop jumping all over. It only jumps when I'm stopped. And it jumps to about 10-15mph. I was wondering if my speed sensors may be dirty. I'm not sure.

Any ideas?
Reply With Quote
  #2  
Old 09-08-2009
mlw20lu's Avatar
Member
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
check ur ground battery cable.
Reply With Quote
  #3  
Old 09-08-2009
Robin Hood's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: AZ
Posts: 789
wouldn't my battery light flash if that was the issue
Reply With Quote
  #4  
Old 09-08-2009
veNom_bz's Avatar
Member
 
Join Date: Jan 2009
Location: Belmopan, Cayo
Posts: 57
check that the speed sensors are seated and connected properly
Reply With Quote
  #5  
Old 09-08-2009
shadow905's Avatar
Member
iTrader: (10)
 
Join Date: May 2006
Location: Boerne, TX
Posts: 1,997
my rpm gauge does the same thing. from what i understand, its a cluster problem. maybe try cleaning all the contacts on the speed sensor and in the cluster. ive never gotten around to doing it.
Reply With Quote
  #6  
Old 09-08-2009
Robin Hood's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: AZ
Posts: 789
nope. ground cable was loose. Fixed it. At least for now it did. I'll check it tonight after I drive for a while.
Reply With Quote
  #7  
Old 09-09-2009
Robin Hood's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: AZ
Posts: 789
confirmed. its fixed. thanks!
Reply With Quote
  #8  
Old 09-09-2009
joatmon's Avatar
Member
 
Join Date: Jul 2007
Location: SMC MD
Posts: 54
Quote:
Originally Posted by mlw20lu View Post
check ur ground battery cable.
good call! That's not an obvious first thing to check
Reply With Quote
  #9  
Old 09-09-2009
veNom_bz's Avatar
Member
 
Join Date: Jan 2009
Location: Belmopan, Cayo
Posts: 57
Quote:
Originally Posted by joatmon View Post
good call! That's not an obvious first thing to check
he has experience...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
speedo noisy and jumping iank1 General Technical & Electrical 1 10-26-2013 01:34 PM
Jumping speedometer fix wvcat General Technical & Electrical 12 07-24-2007 11:13 PM
Speedo Jumping? SteveOh General Technical & Electrical 16 03-12-2007 08:43 PM
Windows are Jumping.. Strider0O0 Interior Semi-Tech 8 03-31-2006 11:04 PM
steering is jumping around a bit. what is it wdstone Suspension Tech 5 06-11-2005 06:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:54 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.