Speedometer not working. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-03-2009
offroadn_redneck's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
Speedometer not working.

I did a quick search and found nothing close to my problem. Then again it was a quick search. Anyway, here is my problem,

I just got my truck today (finally) and I go to take it for a spin. Come to find out, the speedo doesnt work. All the other guages work though. So I had come to the conclusion that a wire came loose on the cluster, so I plugged in my handy-dandy scangauge to see if that would read it. And yep, you guessed it, no worky-worky. So is there something I overlooked? I am not a car guy in any way. I just know how to drive them and fix little problems that require no more than WD-40 and chewing gum.

Oh, and does anyone know how to turn on the dad-gum fog lights? I cant find a switch anywhere.

Thanks
Reply With Quote
  #2  
Old 03-03-2009
braddokxlt's Avatar
Member
 
Join Date: Jan 2008
Location: woodbridge VA
Posts: 342
coulda broke the speed senser i belive you eather have one in the tranny or front axle if its a 4x4
Reply With Quote
  #3  
Old 03-03-2009
offroadn_redneck's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
Its a 2wd. And how much would one of those run for?
Reply With Quote
  #4  
Old 03-03-2009
braddokxlt's Avatar
Member
 
Join Date: Jan 2008
Location: woodbridge VA
Posts: 342
i couldent tell you ive never had to replace mine
Reply With Quote
  #5  
Old 03-03-2009
offroadn_redneck's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
How bout the fog lights? :P
Reply With Quote
  #6  
Old 03-03-2009
braddokxlt's Avatar
Member
 
Join Date: Jan 2008
Location: woodbridge VA
Posts: 342
there should be a switch on your radio bezel
Reply With Quote
  #7  
Old 03-03-2009
offroadn_redneck's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
Huh? Such big words.....
Reply With Quote
  #8  
Old 03-03-2009
TrucknGolf's Avatar
Member
 
Join Date: Nov 2008
Location: Colorado
Posts: 1,829
Dome light work?
Reply With Quote
  #9  
Old 03-03-2009
offroadn_redneck's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
I dont even know if I have one.
Reply With Quote
  #10  
Old 03-03-2009
chainfire's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2007
Location: Mission B.C.
Posts: 3,126
Quote:
I dont even know if I have one.
Look up?

There is a thing called a radio bezel, I dont really know the location of this one, but it shoud be near your radio...

Reply With Quote
  #11  
Old 03-03-2009
offroadn_redneck's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
Nope. I didnt see that button. But I know I have fogs on it. I tried high beams to see if that was it, nope.
Reply With Quote
  #12  
Old 03-03-2009
braddokxlt's Avatar
Member
 
Join Date: Jan 2008
Location: woodbridge VA
Posts: 342
actualy i dont think your gana have a fog light switch that looks like a 01 bumper on a 99 i dont think your truck came with fog lights someone just put a newer bumper on your truck
Reply With Quote
  #13  
Old 03-03-2009
offroadn_redneck's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
I think that might be it. He said he got a new bumper on it. And I just looked on the "radio bezel" and only saw 2 12v outs.
Reply With Quote
  #14  
Old 03-03-2009
braddokxlt's Avatar
Member
 
Join Date: Jan 2008
Location: woodbridge VA
Posts: 342
yea your truck didnt come with fogs just that bumper did to get fogs your gana have to run your own wiring to them and all that fun stuff
Reply With Quote
  #15  
Old 03-03-2009
offroadn_redneck's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 776
lol. Ill wait to do all that good stuff when I find me a roll bar and mount some lights. But first I must get a 3" bl so the 31s stop rubbing when I turn in reverse
Reply With Quote
  #16  
Old 03-03-2009
MemphisSenior's Avatar
Member
 
Join Date: Mar 2007
Location: Spring City, TN
Posts: 331
Dumb question. Have you checked the fuse? Don't know about on the Edge. But on my 2002 XLT 3.0 it's fuse #10
Reply With Quote
  #17  
Old 03-04-2009
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
Quote:
Originally Posted by offroadn_redneck View Post
I just got my truck today (finally) and I go to take it for a spin. Come to find out, the speedo doesnt work. All the other guages work though. So I had come to the conclusion that a wire came loose on the cluster, so I plugged in my handy-dandy scangauge to see if that would read it. And yep, you guessed it, no worky-worky. So is there something I overlooked?
For 98~00, the raw VSS signal comes from a small ABS sensor on top of the rear differential. It is a $20 part and not hard to replace.

You can also open the large square electrical connector under the truck directly below the driver seat. One center bolt holds it together. This connector has a habit of filling with water causing the terminals inside to corrode.

Chances are about 99% that your dead speedo was caused by one of those two.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2000 ford ranger speedometer not working superthrooper General Technical & Electrical 18 03-04-2014 12:51 AM
Speedometer not working with headlights laker General Technical & Electrical 3 01-13-2013 07:04 PM
98 Ranger 5.0 swap, speedometer not working and ABS light on. Ford005 8-Cylinder Tech 11 02-11-2011 08:30 PM
Speedometer not working Mykhael General Technical & Electrical 11 07-03-2009 08:25 PM
Speedometer not working Needforspeed3685 General Ford Ranger Discussion 3 12-09-2007 12:27 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.