sputter on start - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-13-2008
503_94ranger_541's Avatar
Member
Thread Starter
 
Join Date: Dec 2007
Location: wilsonville, or
Posts: 65
sputter on start

so when i park on an incline it chokes and sputters, smooths out after driving a block.. injectors? any ideas?
Reply With Quote
  #2  
Old 03-13-2008
503_94ranger_541's Avatar
Member
Thread Starter
 
Join Date: Dec 2007
Location: wilsonville, or
Posts: 65
ttt
Reply With Quote
  #3  
Old 03-13-2008
503_94ranger_541's Avatar
Member
Thread Starter
 
Join Date: Dec 2007
Location: wilsonville, or
Posts: 65
ttt2
Reply With Quote
  #4  
Old 03-13-2008
Seahawk's Avatar
Member
 
Join Date: Mar 2008
Location: Sheboygan County, WI
Posts: 376
You might want to run some fuel line cleaner through your fuel lines, they could be getting clogged but as more gets through it clears out.
Reply With Quote
  #5  
Old 03-13-2008
spartan72's Avatar
Member
 
Join Date: Nov 2007
Location: Oakwood, GA
Posts: 262
Fuel line cleaner, seafoam, fuel filter, fuel pump. Heck I tried everything fuel related when mine kept dying, dropped about 300 on different components including a MAF and the whole dang problem was my pcv valve and line. You can check all of your fuel components in 45 minutes tops.
Reply With Quote
  #6  
Old 03-13-2008
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
Try turning the key to Run, and listen for the fuel pump to prime it, about 2 seconds.
Turn key to Off, repeat that 3x THEN crank it over to Start.

If that fixes it, your fuel pump check valve is letting fuel pressure leak down when it's not running. Pretty common problem.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 10:53 AM
Ranger hard start issue HELP COLD START 1994splash 2.9L & 3.0L V6 Tech 1 06-08-2011 05:27 PM
Sputter when starting, but not all the time dhugo2 2.3L & 2.5L I4 Tech 3 05-19-2010 06:58 PM
Sputter/Bucking Under Load blackedoutv6 2.9L & 3.0L V6 Tech 7 02-08-2010 09:30 AM
Engine sputter while accelerating feh728 2.9L & 3.0L V6 Tech 8 10-16-2009 07:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:04 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.