Two speed wipers no washer (GEM) - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-21-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Simcoe Ontario
Posts: 5
Two speed wipers no washer (GEM)

I have a Mazda 95 b2300 cab plus 2x4 I have fixed every electrical issue on the truck except one the wipers I have two speeds stupid fast and normal fast the washer comes on at the most inconvenient times except when I want it to i have replaced the switch with a used one disassembled cleaned it first checked all relays and wiring called Mazda technician he told me to bring it to the Ford tech team and they could reprogram GEM well after two hours with Ford tech team they can't reprogram it either to go Mazda I tried replacing it with another module of the same year and model truck with same options except the color witch should not matter I am usually very good with electronics but this one is driving me nuts does anyone happen to know what or where I can get some sort of schematics or diagram for this GEM so I can by pass it without harming the rest of the system any help in that direction would be a great help
Reply With Quote
  #2  
Old 03-21-2016
sheltonfilms's Avatar
Member
 
Join Date: Apr 2010
Location: Knoxville, TN
Posts: 631
Try swapping the two relays and see if it changes anything.

Diagram:
http://www.revbase.com/BBBMotor/Wd/DownloadPdf?id=46791
Reply With Quote
  #3  
Old 03-21-2016
TheArcticWolf1911's Avatar
Member
 
Join Date: Nov 2015
Location: Evansville, Indiana
Posts: 1,667
It's also possible that either the multifunction stalk and/or the GEM are faulty. Although, the multifunction would be the more likely out of the two.
Reply With Quote
  #4  
Old 03-22-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Simcoe Ontario
Posts: 5
Quote:
Originally Posted by TheArcticWolf1911 View Post
It's also possible that either the multifunction stalk and/or the GEM are faulty. Although, the multifunction would be the more likely out of the two.
I have changed the whole multi-switch twice and have changed gem module I even taken the multi-switch completely apart n cleaned it I'm sure it's the gem but I am not spending $400 plus tax to get a new one I don't even have that in the whole truck thanks for your response
Reply With Quote
  #5  
Old 03-22-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Simcoe Ontario
Posts: 5
Reply to your reply

Thank you for the PDF file and the tip on the relays I have. Not tried anything yet but I'll let you no how it goes IE: if I catch anything on fire or fry the PCM lol
Reply With Quote
  #6  
Old 03-22-2016
Member
Thread Starter
 
Join Date: Mar 2016
Location: Simcoe Ontario
Posts: 5
Quote:
Originally Posted by sheltonfilms View Post
Try swapping the two relays and see if it changes anything.

Diagram:
http://www.revbase.com/BBBMotor/Wd/DownloadPdf?id=46791
I tried switching the relays now I only have one speed on the wipers and still no washer I'm back to the original problem
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Please give your two cents... Code P0731 Could it be caused by a Speed Sensor? nross Drivetrain Tech 8 07-27-2017 01:48 PM
FX4 Level 2 Two Tone Color Schemes & 93+ Two Tone Rangers Hillyard Exterior Semi-Tech 1 03-11-2015 09:04 AM
Wipers and Washer Fluid Squirter Stopped working 95whitelightning General Technical & Electrical 6 10-30-2010 09:20 PM
Two months two late! dixie_boysles Wheels & Tires Semi-Tech 19 02-15-2010 04:13 PM
Two tone, or not two tone... Sixt9coug Exterior Semi-Tech 20 12-13-2009 07:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.