1994 won't start. please help. - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-26-2008
Member
Thread Starter
 
Join Date: May 2008
Location: Michigan City, Indiana
Posts: 3
1994 won't start. please help.

I recently bought a 94 ranger. 4 speed, four cylinder, a pretty basic little truck. Last night I parked it in great running condition, this morning it turns over but won't start...I checked the fuel shut-off but it's ok. any help would be appreciated. Thanks.
Reply With Quote
  #2  
Old 05-26-2008
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
fuel pump? fuel filter, maybe somethings clogging the injectors?

Sounds like a fuel issue if its turning over but not kickin up and starting...
Reply With Quote
  #3  
Old 05-26-2008
Member
Thread Starter
 
Join Date: May 2008
Location: Michigan City, Indiana
Posts: 3
Thanks. I just bought the truck less than a month ago and got a great deal on it because it needed a fuel pump. I changed the pump, screen and filter and it's been great up til now. I gave it a little gas while it was cranking over and could smell the odor of gas so I stopped. I would assume because I smelled gas that the pump is still working ok. I dunno...just checked the fuse box, everything looked ok to me.
Reply With Quote
  #4  
Old 05-26-2008
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
Hmm, does anyoen else here have anything to chime in? You would probabyl notice if there was a leak, b8t perhaps it might be good to peek up around all the lines, make sure it isnt pinched off, or not a good contact perhaps.
Reply With Quote
  #5  
Old 05-26-2008
k.blakeley's Avatar
Member
 
Join Date: Apr 2007
Location: East Texas
Posts: 2,823
A motor needs 3 things to run....air,fuel,spark. Start ruling them out.
Reply With Quote
  #6  
Old 05-26-2008
Member
Thread Starter
 
Join Date: May 2008
Location: Michigan City, Indiana
Posts: 3
Thanks guys, I figured it out after hours of work. The problem was a $10 fuel pump relay switch located in the fuse box. I've seen many other postings on other forums about this and it seems nobody had as much luck fixing this problem. I hope this helps somebody else out there. It's been a long day.
Reply With Quote
  #7  
Old 05-27-2008
jeremy4876's Avatar
Member
 
Join Date: Apr 2008
Location: Elyria Township
Posts: 98
If you had to change the fuel pump relay ,change the ECM relay too they look alike (might even be the same relay) I have owned 2 '94 2.3's and they both had the same problem . one relay usually fails within weeks of the other.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Very weird! Won't start, won't shut off, flashing exterior lights fletcher969 2.9L & 3.0L V6 Tech 4 01-14-2013 06:26 PM
LOOK! Car won't start thread! I did search, please help! jayellcowen SOHC - 2.3L & 2.5L Lima Engines 15 06-15-2011 11:55 PM
97 ranger won't start please help if u can thanks strokerace31558 SOHC - 2.3L & 2.5L Lima Engines 17 08-24-2010 08:26 PM
97 ranger won't start please help if u can thanks strokerace31558 General Technical & Electrical 1 08-20-2010 05:45 PM
Won't crank/start! Please help! Brandon77 General Technical & Electrical 21 09-16-2009 04:37 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.