2.3L Starting Problems.... - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-12-2009
dixie_boysles's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2006
Location: NC
Posts: 3,778
2.3L Starting Problems....

I just tlaked to the guy who i sold my 94 ranger to...and he says the truck is doing great minus one problem...it is the same problem that started about a week before i sold it!

the problem is sometime after it has been driven and cranked a few times, say you stop at a gas station get gas, crank it, it cranks fine. Stop somewhere else, do what you gotta do, crank it, it cranks fine. then you stop again, and go to crank it and it WONT crank...wth

i know its in the fuel system somewhere. i replaced a fuel pump on it 2 years ago.

the reason i know its the fuel system is bc when it does this, you can pull the puel pump relay put it back in, and it will crank fine...

i replaced it and it still does it....he replaced the relay and it still does it...what gives...

i could be wrong, but it sounds like the aftermarket fulpup is messed up...what about ya'll guys...any other suggestions....?


i miss the ol truck, but it had a few probs (the cooling system has mud in it, not really buts its real rusted---rearend going out, he said the clutch felt weak now, and i know it need a rear seal.

i could fixed all these probs with prolly two of my current truck pauments, but i didnt feel it was worth it....

other than these, it is a great truck that runs GREAT especially w/ 190000 miles on it! (i bought it with 120k and sold it with 179k....)

any help here guys would be great to get the ol girl starting right...
Reply With Quote
  #2  
Old 06-12-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Okay you first need to clarify your terminology .
Cranking means the engine is turning over when the key is turned.
Starting means the engine fires and runs on its own.

So , do you have a cranking issue or a starting issue ?
A bad fuel pump has nothing to do with cranking .
Reply With Quote
  #3  
Old 06-12-2009
dixie_boysles's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2006
Location: NC
Posts: 3,778
Quote:
Originally Posted by OTRtech View Post
Okay you first need to clarify your terminology .
Cranking means the engine is turning over when the key is turned.
Starting means the engine fires and runs on its own.

So , do you have a cranking issue or a starting issue ?
A bad fuel pump has nothing to do with cranking .
okay....the first few times, it "starts" just fine, runs smoothly....

then the next time it "cranks" but doesnt "start". the engine is turning over, but never starts until you pull the relay and put it back in...
Reply With Quote
  #4  
Old 06-12-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Most likely a bad pump relay or the key switch.
Listen every time you first turn the key to run before cranking for the fuel pump , it'll be a slight whining sound for a second.

edit : bad pump relay connection
Reply With Quote
  #5  
Old 06-12-2009
dixie_boysles's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2006
Location: NC
Posts: 3,778
Quote:
Originally Posted by OTRtech View Post
Most likely a bad pump relay or the key switch.
Listen every time you first turn the key to run before cranking for the fuel pump , it'll be a slight whining sound for a second.

edit : bad pump relay connection


yeah you can hear it when it starts fine...but you cant when it dont....

i dont think its the relay bc its been replaced twice..., HAS to be pump huh
Reply With Quote
  #6  
Old 06-12-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Did you check the connections at the cut-off switch down by the passengers side kick panel ?
Reply With Quote
  #7  
Old 06-12-2009
dixie_boysles's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2006
Location: NC
Posts: 3,778
nope ill tell him to check that....
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Starting Problems patkelly1336 4.0L OHV & SOHC V6 Tech 0 04-06-2011 05:57 PM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 11:33 AM
Starting problems...HELP!! rangererv 4.0L OHV & SOHC V6 Tech 9 08-04-2005 01:01 PM
Starting problems Just Plain Dave General Technical & Electrical 6 07-10-2005 08:43 PM
problems starting up ihatefords2 DOHC - 2.3L Duratec / Mazda L Engines 6 06-01-2005 09:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.