2000 Ranger xlt 2.5L 5 speed rev/surge issue - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-28-2016
Member
Thread Starter
 
Join Date: Feb 2016
Location: Milwaukee Wisconsin
Posts: 2
2000 Ranger xlt 2.5L 5 speed rev/surge issue

Hello everyone im new to the forum as a member but not a vistor lol.. Im am having an issue with my truck, it seems to do whatever it wants i have replaced the IACV,PCV, MAF,TPS, new gaskets for TB and intake manifold when i did a full tune up, have checked for vacuum leaks there are none. I tried running a afywrmarket intake set up as well. Still the truck just revs like crazy when it wants mostly when in nuetral and rolling up to a light, i have searched forum after forum for an answer but nothing seems to help. For the longest time there was no CEL now it comes on for IACV faulty circut but if i clear the code sometimes it comes.back sometimes it doesnt, currently is on. If anyone has experienced this and has any advice i would greatly appreciate it.
Reply With Quote
  #2  
Old 02-28-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,595
Google: ford tsb 00-3-5 - Publication Date: JANUARY 31, 2000

This applies to your truck.

IAC valve faulty circuit means loose connection, so that needs to be checked as well.


But just to check for vacuum leaks, after engine is warmed up and idling, unplug IAC Valve, it should close and idle should drop to 500rpms or engine may even stall, either is good, no leaks.

If idle stays high, 800+, then start unhooking vacuum hoses and plug the port with your finger, if idle drops then that hose or its device has a leak
Reply With Quote
  #3  
Old 03-01-2016
Member
Thread Starter
 
Join Date: Feb 2016
Location: Milwaukee Wisconsin
Posts: 2
I did pull the IACV it didnt die but did drop down. I did check the individual lines for crack or holesnor anything and replaced 2 of them as well as the line fornthe PCV as welll as PCV. I checked all thenconnections and plugs and cleaned them and put a little bit of dielectric grease in most of them. As far as my grandfather and I see them the connection are good. He even checked the connectorsnon the harness to make sure power was going through. The thing that throws us off is that it does all the time it will do it in nuetral idleing it will do it in gear and rolling in neutral. So any other ideas i will appreciate injust wanna fix it so sick of dropping money into for something else to not work hence the revving its the last thing I need to fix.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Idle Rev and Surge - then stall Ahabiam General Technical & Electrical 31 10-12-2017 08:17 PM
96 Ford Ranger XLT 2.3L 5 Speed Idle Issue hunter13d SOHC - 2.3L & 2.5L Lima Engines 3 04-10-2015 12:00 PM
2000 Ranger 3.0 Flex Fuel High Rev Problem MissMechanic34601 2.9L & 3.0L V6 Tech 1 11-27-2014 11:08 AM
93 Ranger Skip or Surge ?? HELP Swifgriff General Ford Ranger Discussion 5 04-10-2011 06:53 AM
2000 ranger 2.5 speed sensor/speedo issue johnnieh93 General Technical & Electrical 8 05-24-2010 09:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:08 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.