96 misses sometimes - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-06-2012
Member
Thread Starter
 
Join Date: Jan 2012
Location: Excelsior Springs
Posts: 5
96 misses sometimes

Hi, I new here. I have a 96 with 214k miles. it has started to run rough when I rev it to 2500 or so and let off. It will almost die and sometimes does.

It has new plugs, wires, coil, sparkplug mod on other coil. Chech engine light flashes sometimes. po301 code. What would be next??

I did replace some bad vac lines.
Reply With Quote
  #2  
Old 05-06-2012
Member
 
Join Date: Feb 2012
Location: Windsor, WI
Posts: 93
Quote:
Originally Posted by vac prob View Post
Hi, I new here. I have a 96 with 214k miles. it has started to run rough when I rev it to 2500 or so and let off. It will almost die and sometimes does.

It has new plugs, wires, coil, sparkplug mod on other coil. Chech engine light flashes sometimes. po301 code. What would be next??

I did replace some bad vac lines.
P0301 code means misffire on #1 clyinder.

Have you c;eamed the IAC and Throttle body lately, if not I would start there.

Do you use any injector cleaner, if not try chevron or B12.

Could be injector problem.Check the pulse of the injector with a screwdriver to your ear and see if the clicking is like the others.
Reply With Quote
  #3  
Old 05-06-2012
Member
Thread Starter
 
Join Date: Jan 2012
Location: Excelsior Springs
Posts: 5
Thanks, I will try the throttle body. When its idle is good, if I unplug the IAC it idles rough. I have used Lucas injector cleaner. I will try the B12 or chevron. When it stops raining I will check the injector.
Thanks!!
Reply With Quote
  #4  
Old 05-10-2012
Member
Thread Starter
 
Join Date: Jan 2012
Location: Excelsior Springs
Posts: 5
The injector is clicking like the others. I ran a tank with chevron in it also. The throttle body was not too bad......
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My turn with the misses Puddinhead 2.9L & 3.0L V6 Tech 24 04-23-2011 07:32 AM
Help Ranger Misses bobs3015 2.9L & 3.0L V6 Tech 0 02-17-2011 08:12 AM
when it snows it misses!!! jrex General Technical & Electrical 5 12-10-2010 07:57 PM
96 Ranger Stalls and Misses when Accelerating and Low RPM's acleme1 2.9L & 3.0L V6 Tech 1 10-03-2008 07:32 AM
Misses letting off of throttle ckbwv SOHC - 2.3L & 2.5L Lima Engines 0 03-30-2008 07:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.