97 2.3L Bad idle... - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-09-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Pampa Tx
Posts: 5
97 2.3L Bad idle...

Recently found a ranger in a field, bought it, replaced the head that was cracked and it ran fine for the first 7 months or so. About 3 weeks ago though it started having a gassy odor/burnt water odor when driving. It also started idling crazily at an idle, up then down to a near stall out, if i stomp on the gas though it will go away and idle normal for about two mins then do it again. Once in gear and going it runs fine..... more of a diesel junkie so im stuck on this. Any help would be appreciated.
Reply With Quote
  #2  
Old 08-09-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
when you put the head on did you check the block for warpage? and also did you replace the head bolts and torque them down?
Reply With Quote
  #3  
Old 08-10-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Pampa Tx
Posts: 5
Yes, there was no warpage, and bolts were rplaced and torqued down to specifications. One of my brothers mentioned that it could be the TPS sensor, or MAF sensor, any lavidity in this statement??
Reply With Quote
  #4  
Old 08-10-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
IAC
Reply With Quote
  #5  
Old 08-11-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
any codes?
Reply With Quote
  #6  
Old 08-11-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Pampa Tx
Posts: 5
A code stating running rich, and one stating bad injectors, just replaced injectors today, still have the bad idle!
Reply With Quote
  #7  
Old 08-16-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Pampa Tx
Posts: 5
Also as of today whenever I pull off the egine oil fill cap it falters and dies EVERY time...... really would like to know WTH is wrong with this truck lol, its 22 MPG beats my f-250s 12MPG
Reply With Quote
  #8  
Old 08-17-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
try putting a pcv in.
Reply With Quote
  #9  
Old 08-20-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Pampa Tx
Posts: 5
Did a PCV and O2s like the codes read out, but still same problem, even though the idle is tons smoother it still drops and dies
Reply With Quote
  #10  
Old 08-21-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
if it is running rich, and you already replaced the injectors check/ replace your regulator.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
low idle when slowing down to idle j_huhnke 4.0L OHV & SOHC V6 Tech 2 03-25-2012 10:26 AM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM
The_Dealer: Bad Deal Bad Member Bad Sell! LayingFrame89 Ranger Products, Company, & Member Reviews 34 12-01-2007 07:59 AM
Stock Drivesaft with RCD = BAD BAD BAD PICS INSIDE ranger General Ford Ranger Discussion 32 07-31-2007 12:50 PM
ALL offroaders are BAD BAD BAD! FMD General Ford Ranger Discussion 13 04-25-2006 08:21 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.