air only blows out the dash defroster - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-22-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: la
Posts: 6
air only blows out the dash defroster

i have a 99 ranger with 2.5 and i can position the air to blow anywhere i want and it still will always blow out of the defroster. anything i can do to fix this. fromwhat i have read it is a vaccum leak. but not sure where i need some help please. where its at what it looks like and how to fix it. thanks
Reply With Quote
  #2  
Old 06-23-2010
Member
 
Join Date: Jun 2010
Location: lawrenceville, GA
Posts: 5
Is your air conditioner working on regular setting or do you have to switch it to max ac to get the ac to work? I have the problem with the regular ac setting only blowing out hot air. I had a friend look at it and there is an air door under the dash on the passenger side that is not closing all of the way and does not allow the ac to blow out on regular, but it is straight defrost on that setting. The part for that door is cheap but the labor is about 8 hours for a mechanic. Hope that helped.
Reply With Quote
  #3  
Old 06-23-2010
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by lmilhorn View Post
i have a 99 ranger with 2.5 and i can position the air to blow anywhere i want and it still will always blow out of the defroster. anything i can do to fix this. fromwhat i have read it is a vaccum leak. but not sure where i need some help please. where its at what it looks like and how to fix it. thanks
Trace the plastic vacuum lines running from and near the passenger side of the engine. May be melted/broken/disconnected. Look at the vacuum harness and individual vacuum lines under the passenger side of the dash. Also, the plastic vacuum reservoir which may be cracked - the location varies by year but I believe that the 99 is between the inner and outer fenders on the passenger side.
Reply With Quote
  #4  
Old 06-23-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: la
Posts: 6
no it blows out air no matter what the setting is out the defroster. and i looked at the door and that door is always closed. and it never open. is it supposed to open.
Reply With Quote
  #5  
Old 06-23-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: la
Posts: 6
well i haven't tried it on reg ac but if i just put it on the vent it blows warm air through the defrost and i thought the door on passenger side was supposed to stay closed . rite.
Reply With Quote
  #6  
Old 06-24-2010
Member
 
Join Date: Jun 2010
Location: jacksonville,florida
Posts: 32
you may have to replace the gem box behind your radio i had the same problem with mine.
Reply With Quote
  #7  
Old 06-24-2010
JoshK's Avatar
Member
 
Join Date: Sep 2006
Location: CC, Indiana
Posts: 3,832
Have you checked the fuse?
Reply With Quote
  #8  
Old 06-24-2010
ColdNapalm's Avatar
Member
 
Join Date: Sep 2008
Location: Jacksonville, Florida
Posts: 499
i had the same problem with my ranger blew cold air only through the dash... but the hot windshield canceled the ac effect... ended up selling it like it was never figured it out..
Reply With Quote
  #9  
Old 06-24-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: la
Posts: 6
where is that box and no i have not and what does it look like. fuses are good.
Reply With Quote
  #10  
Old 06-24-2010
wildbill's Avatar
Member
 
Join Date: Oct 2009
Location: Crestwood
Posts: 308
The vents operate off a vacuum, not electrical circuits so it's not a fuse. Defrost is the default setting, and a vacuum is required to move the dampers to funnel the air elsewhere. Pull your radio and make sure the plastic vacuum tubes running to the controls are not smashed or kinked. You'll probably need a new vacuum reservoir if those control tubes are ok and the tubes under the hood running out the reservoir are ok.
Reply With Quote
  #11  
Old 06-24-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: la
Posts: 6
yeah checked those and the tubes are ok. my check engine light came on and i went to get it checked and found out my EGR valve is bad. could that cause it. where is the reservior your talking about and what does it look like.
Reply With Quote
  #12  
Old 06-24-2010
Member
 
Join Date: Jun 2010
Location: jacksonville,florida
Posts: 32
the gem box is located be hind the radio you will see a box on the left and one on the right the gem is the left side box and its farily cheap i picked one up at a local junk yard for 10 bucks and problem solved very easy to change just un plug it
Reply With Quote
  #13  
Old 07-17-2015
Member
 
Join Date: Jul 2015
Location: Jefferson,GA
Posts: 1
Did anyone ever answer you about this? I am having the exact same issues. My air blows cold but only out of the defrost vents. My check engine light is on and the code is for a bad EGR valve. I have been all over the internet trying to find out what the issue could be. Any help you could provide would be appreciated!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Air only blows through top dash vents... Deftsound General Technical & Electrical 51 07-12-2017 06:45 PM
Air only blows through dash defrost on all settings floor,vent. Only blows wide open? cseay99 SOHC - 2.3L & 2.5L Lima Engines 4 12-08-2011 10:42 AM
Only Hot Air Blows Through Defrost All The Time *PLEASE HELP* mx49dad General Technical & Electrical 4 03-08-2011 07:14 PM
ac only blowing out the defroster .. bad FUSE? wdstone General Technical & Electrical 23 07-11-2005 03:45 PM
air wont blow out of vents .. only defroster wdstone General Technical & Electrical 16 06-29-2005 06:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:41 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.