Cooling System Help Please? - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-26-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: Raymond, NH
Posts: 1
Cooling System Help Please?

Hi Everyone!
I'm brand new to this forum, looking for help troubleshooting cooling system problem in my 1998 Ranger 4Cyl. 2.5 Liter. Here's a summary of what's been going on. I'd appreciate your comments/suggestions if anyone has heard of this set of contradictions in their ranger's cooling system. Thanks!
I got my ranger last winter, noticed how it took a long time to heat up to temp... I got heat, but barely enough, after 10 miles hi-way driving. The temp guage needle never rose far above Cold mark! Otherwise, all was fine, ran great.
Then all at once while driving on hwy, I heard "clicking" water-pump sound, smelled anti-freeze, and temp needle was half-way up to middle, I thought I was overheating, but nothing was leaking, and it cooled back down when I stopped. Ever since this, I hear a light "hissing" when I accelerate, when its up to temp.
I got the thermostat replaced recently, but now it heats up too much, too fast, gauge needle right up to middle, and now I MUST run heat on high-fan just to keep from over-heating it, and avoiding that dreaded "clicking" water-pump sound.
Oddly, when it idles, it still stays cool... even after 20 mins idling in warm weather! Also, after 20-mins hwy driving, I stopped because it was too hot, but felt bottom lower hose... ice cold!
What's going on here? PS: Anti-freeze looks fine... bright green & clear, no visible corrosion anywhere.
Thanks, BeeDee
Reply With Quote
  #2  
Old 04-26-2008
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Bad water pump or clogged radiator.
Reply With Quote
  #3  
Old 04-28-2008
Djt1994's Avatar
Member
 
Join Date: Mar 2008
Location: Niagara Falls, New York
Posts: 59
Have the cooling system flushed but you probably have a bad water pump.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ok now it's just screwing with me. 97 Ranger cooling help please. Fishmaster General Technical & Electrical 8 10-30-2011 04:42 PM
Help With Cooling System dagored11 2.9L & 3.0L V6 Tech 2 05-10-2010 09:26 AM
HELP! Flushed cooling system before realizing I only have DexCool Needforspeed3685 General Ford Ranger Discussion 16 03-19-2010 08:43 PM
new cooling system(engine) now leaking mps01r6 2.3L & 2.5L I4 Tech 1 12-16-2008 12:15 PM
Cooling System Problem Need help JTG 2.9L & 3.0L V6 Tech 3 08-24-2007 08:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:58 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.