Got the old ranger runing and colant porrs out the side - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-21-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
Icon4 Got the old ranger runing and colant porrs out the side

Like the title says collant poors out on drivers side all i can see is it running from somewhere above the oil filter i cant figure it out this is right after n engine swap and i was trying to fill it back up thanks
Reply With Quote
  #2  
Old 08-22-2011
sheltonfilms's Avatar
Member
 
Join Date: Apr 2010
Location: Knoxville, TN
Posts: 631
Sounds like a head gasket. I would rent a pressure tester and connect it to your radiator cap hole and pump it up to see where its leaking.
Reply With Quote
  #3  
Old 08-22-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Hope it's just a core plug (some call them freeze plugs) rotted out.
Reply With Quote
  #4  
Old 08-23-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
It appears to be leaking from a port in the lower intake where the colant flows pasr a heat sensor now tge 93 didnt have a sensor there like the 89's does and idk if the engine will run rigjt without them because of the computer, i also used gasket maker since the origional gasket was junk, so idk if the origonal intake on the 93 was warped to the head and thays why the 89's intake leaks or if i failes to pute enough gasket maker around there
Reply With Quote
  #5  
Old 08-23-2011
Member
Thread Starter
 
Join Date: Oct 2010
Location: aspers, PA
Posts: 801
Other than that the engine runs amazing yet but i cant run it long until i fix this
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
old ladie and i got in fight truck got the worst of it silverfox Drivetrain Tech 17 01-21-2014 03:46 PM
help with runing lights Toomanycars General Technical & Electrical 5 03-12-2012 08:48 AM
runing rich and i cant figure out y derousse1985 4.0L OHV & SOHC V6 Tech 4 10-31-2011 06:13 PM
Got her up and runing again, and a question. thesoundmaster General Technical & Electrical 2 01-11-2008 09:46 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:46 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.