Possible fix for sticky high idle - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-10-2015
Member
Thread Starter
 
Join Date: Aug 2015
Location: Saugus, MA
Posts: 5
Possible fix for sticky high idle

Ok, so in August I picked up a 2000 Ranger, 2WD, 5MT with 150k on it. its a bit of a crapcan but I picked it up CHEEP! but I guess the old saying goes: Cheap cars aren't good and good cars aren't cheap.

So it had the rough idle, P0171 p0457. So in the quest to shut off the CEL and to get it reliable for the colder months Here's what I've ended up changing (based on the feedback from this forum):

• Complete tune up, including PCV, all eight sparkplugs
•Intake manafold, ISV and throttle body clean/regasket (cleaning the walls of the throttle body with TB cleaner and removing all carbon buildup)
•Fuel pump/fuel pump regulator
•EGR valve with EGR valve vacuum box
--- none of this worked, Sill had the sticky idle (even though the truck ran SMOOTHER).
•complete exhaust from the manifold back
•BOTH 02 sensors
---- CEL light went out, all errors cleared but the idle problem remained
•Idle stablizer valve, charge air temp sensor, throttle position sensor
-----truck ran MUCH better but upon coast-down, it would hang at 1500 RPM, then, when the truck was at a complete stop, it would idle normally
•Throttle Position Sensor CONNECTOR
----- this HAS solved the problem. truck idles correctly, both under power and coasting to neutral, truck idles correctly.
Reply With Quote
  #2  
Old 10-11-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,582
Good info, thanks.

Just FYI, manual trans vehicles should hold higher idle when you push in the clutch pedal while moving, then when below 5mph the idle should drop to "normal" for engine temp.

With clutch in the idle will stay high for 2 to 5 seconds then drop to about 1,100rpm when shifting, this gives better mpg and lower emissions, then when below 5mph idle will drop down again
Reply With Quote
  #3  
Old 10-12-2015
Member
Thread Starter
 
Join Date: Aug 2015
Location: Saugus, MA
Posts: 5
Sure, It functions like that now, prior to that, the idle would stay at 1500 rpm for about 30 sec during a full stop. Or, randomly the idle would sit at 3k rpm then climb unitl I shut the truck down, or eventually hunt down to 1500, THEN drop to normal operating idle. But the worst part woudl be as I cycle through the gears to get to traffic travel speed, the idle would raise between gears. Then when I achieved 50/55 mph, the idle would stick there, it would act as if i had cruise control engaged.
The worst of this problem occurred before I changed the ISV, but just changing it didn't completely solve the problem. the idle would hang too long in too many different, random circumstances for it to be "factory correct". More importantly, it was too unpredictable to considered safe in my book.
As far as i'm concerned, I'd let a family member borrow the truck now as needed and not have to explain "ok, if you get a weird idle, shut it down and bla bla bla". Its been four days now and its running as it should. But thanks for the info, all input is more than helpful!
Reply With Quote
  #4  
Old 10-12-2015
Member
 
Join Date: Oct 2013
Location: gardiner, me
Posts: 22
I have the same issue, where is the throttle position sensor?, is this something you cleaned or replaced? thx for the help
Reply With Quote
  #5  
Old 10-13-2015
Member
Thread Starter
 
Join Date: Aug 2015
Location: Saugus, MA
Posts: 5
Quote:
Originally Posted by terry603 View Post
I have the same issue, where is the throttle position sensor?, is this something you cleaned or replaced? thx for the help
I'm not sure its the same fix for the 4.0 trucks but the throttle sensor sits just alongside the throttle body, It'll be a black box with a torx or phillips. There's a three pronged connector. Honestly, I wish I'd have changed the connector first, my truck has never run better since i've owned it.
Reply With Quote
  #6  
Old 10-14-2015
Member
 
Join Date: Oct 2013
Location: gardiner, me
Posts: 22
thx, I ordered one, hope it also solves my idle problem
FYI, it did not fix the problem .\

I am still trying to solve this..
changed this and the AIC valve

Last edited by terry603; 10-19-2015 at 12:50 AM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Slip Yoke (Possible Sticky) acortez Drivetrain Tech 35 08-26-2014 09:33 PM
High Idle / Low idle 2003 Ranger 3.0 thom2003 2.9L & 3.0L V6 Tech 1 03-27-2012 01:12 AM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM
Can this possible fix my Line of Fire? GR8COM Exterior Semi-Tech 31 02-07-2009 07:43 PM
sticky/hanging idle problem still...... Jeremy102579 General Technical & Electrical 1 04-02-2008 01:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.