Somethings missing. - Ranger-Forums - The Ultimate Ford Ranger Resource


Suspension Tech General discussion of suspension for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-22-2009
tom kalmanidis's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: Broad Brook, CT
Posts: 204
Somethings missing.

I noticed that there was something missing. What exactly is that called? I'm so mindless right now in my life when it comes to trucks. I'm new to this. (Don't be so harsh with the comments, have heart.)


Yes, there's rust.(New England)
Name:  P4214149.jpg
Views: 1
Size:  113.2 KB
Reply With Quote
  #2  
Old 04-22-2009
David N's Avatar
Member
 
Join Date: Dec 2008
Location: Williamston, NC
Posts: 1,060
Part of your sway arm? Maybe? Im not sure either.
Reply With Quote
  #3  
Old 04-22-2009
Motorcraft's Avatar
Member
 
Join Date: Jul 2005
Location: Franklin MA
Posts: 240
swap bar end link bolt.
Reply With Quote
  #4  
Old 04-22-2009
tom kalmanidis's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: Broad Brook, CT
Posts: 204
Could i still drive on it until i get a bolt?
Reply With Quote
  #5  
Old 04-22-2009
NVRDONE's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2009
Location: Union, NJ
Posts: 114
Yeah you can but taking turns will suck. I'd get a new one ASAP.
Reply With Quote
  #6  
Old 04-22-2009
Member
 
Join Date: Nov 2007
Location: Chillicothe, Oh
Posts: 72
I had the same problem. It will lean real bad in corners so take it easy. That is the sway bar end link and it's $15.00 at autozone. Easy fix, no need to take tire off or anything. Just use vice grips on the middle section to hold it from turning and take off the bottom nut, remove. The new one is one long bolt with washers, bushing and a nut for the bottom.

Sway bar end link repair kit, Go here....

http://www.autozone.com/autozone/cat...questid=242656
Reply With Quote
  #7  
Old 04-22-2009
tom kalmanidis's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: Broad Brook, CT
Posts: 204
Thanks guys.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Somethings missing here DelaRanger95' Snapshots 9 04-21-2011 11:43 AM
Somethings missing!!!!!!!!!!!1111!! Danger06Ranger Snapshots 37 07-13-2009 11:59 PM
Somethings wrong with my account -- attachments dissappeared AGAIN n3elz Ranger-Forums Office 15 01-29-2008 11:37 AM
Somethings messed up? 2003stealthedge 2.9L & 3.0L V6 Tech 4 11-23-2006 09:36 PM
somethings wrong rangerdriver01 4.0L OHV & SOHC V6 Tech 3 05-17-2006 07:46 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.