Cam position sensor help please - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 2.9L & 3.0L V6 Tech

2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 11-30-2008
Thread Starter

I am: Nick Nonya
Join Date: Oct 2008
Location: Bradenton,fl
Vehicle: 2002 Ford Edge ranger
Posts: 4
Total Props: 0
Cam position sensor help please

It all started when I noticed a Chirp under the hood a few days ago. Sometimes it's there sometimes it's not, sometimes it gets louder sometimes it gets quieter. I thought it was the belt at first but after spraying wd40 on it I figured that it wasn't so I thought it was a pulley so I ran it without the belt and still heard the chirping. I traced the noise back to the firewall. I think its that cam position sensor thing that everybody keeps talking about. It's a 2002 3.0 liter 4X2. I can't seem to find it though. I found something that looks similar to a distributor. Its on the back of the engine close to the fire wall on the passenger side. Is that it? if not where is it? Thank you so much
Reply With Quote
+ 0 -
Old 11-30-2008
Level I Supporter
I am: Bob Ayers
Join Date: Aug 2006
Location: Durham, NC
Vehicle: 1999 Ford Ranger
Posts: 3,654
Total Props: 3
YUP, you found it! It's located where you would expect a distributer to be.
Reply With Quote
+ 0 -
Old 11-30-2008
darkstar_420's Avatar
I am: R P
Join Date: Feb 2008
Location: sk
Vehicle: 2000 Ford Ranger, 1986 Fo
Posts: 621
Total Props: 0
my check engine light kept coming on, codes were reading cam pos. sensor, ford checked it out and it was all good, light came on again same thing, ford checked it again all good now it doesnt come on :)
Reply With Quote
+ 0 -
Old 11-30-2008
Toreador4x4's Avatar
Level III Supporter
iTrader: (6)
I am: Justin Higgs
Join Date: Apr 2007
Location: Livonia, MI
Vehicle: 1998 Ford Ranger
Posts: 3,958
Total Props: 15
if it is starting to squeak, you should replace it before it locks up and breaks the cam off and ruins the oil pump.

everyone will tell you that you have to remove the upper intake to change it but you dont. PM me if you need to know hoe to replace it or whatever
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
3.0 Cam shaft position sensor bigred08046 2.9L & 3.0L V6 Tech 5 09-28-2010 03:48 PM
4.0 OHV cam position sensor help! j99ranger4x4 4.0L OHV & SOHC V6 Tech 17 07-06-2010 03:20 PM
'94 Mazda 4.0L cam position sensor IslandFord 4.0L OHV & SOHC V6 Tech 2 05-19-2010 07:35 AM
How to replace a cam position sensor Thedangerranger 2.9L & 3.0L V6 Tech 3 12-04-2008 07:20 AM
Bad Cam Position Sensor? Srkasner 4.0L OHV & SOHC V6 Tech 3 08-17-2008 06:18 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 04:02 PM.