Engine Misfire - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 01-18-2010
Thread Starter

I am: Josh Ellis
Join Date: Jun 2009
Location: Saltville, VA
Vehicle: 1991 Ford Ranger
Posts: 3
Total Props: 0
Engine Misfire

Anbody have any suggestions. Ive got a 91 ranger w/ 4.0liter. Idles fine and seems to do ok if you a light on the throttle. If you get on the throttle it feels like you a losing a cylinder. ive replaced plugs, coil, checked maf sensor (data within spec). Wire were replaced not to long ago. could i still possibly have a bad wire.
Reply With Quote
+ 0 -
Old 01-18-2010
powerranger262's Avatar
iTrader: (1)
I am: Nate G
Join Date: Feb 2009
Location: Hartford, WI
Vehicle: 2002 Ford Ranger FX4
Posts: 1,222
Total Props: 6
I have had the same thing. I just got done cleaning the throttle body, MAF, intake tube, and the IAC. It's gone as far as I can tell, definately runs a lot smoother. I'll get to drive a little bit more tomorrow to see if it is completly gone.
Reply With Quote
+ 0 -
Old 01-18-2010
I am: Ken Here
Join Date: Mar 2007
Location: Upstate,NY
Vehicle: 2003,Ranger
Posts: 2,598
Total Props: 13
I had this on a Dodge V8.
Moisture had gotten in the fuel system and over time had caused rust particles to build up and plug an injector. It would pass enough fuel at idle and light throttle but hard throttle it would drop a cylinder.
I fixed it by removing the injectors and using carb cleaner with the extension tube ,blow the crap out of the input side of the injector.

edit to add
Change the fuel filter if you haven't already

Last edited by OTRtech; 01-19-2010 at 09:56 AM.
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine misfire? crackerskwirl36 2.9L & 3.0L V6 Tech 4 04-19-2010 09:57 PM
Engine Misfire mnattymagee General Technical & Electrical 2 02-13-2010 12:57 PM
99 3.0 engine Misfire RangerJacoby99 2.9L & 3.0L V6 Tech 3 04-16-2009 07:35 PM
help misfire after i washed engine? vic 2.9L & 3.0L V6 Tech 3 08-13-2006 12:37 PM
Engine misfire???? phatspeed7x 4.0L OHV & SOHC V6 Tech 4 07-02-2006 08:08 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 06:09 AM.