Temp sending unit - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-11-2004
Diabolic's Avatar
Member
Thread Starter
 
Join Date: Sep 2004
Location: Rising Sun, MD
Posts: 1,542
Could someone point me in the direction of where the temperature sending unit is located? Mine went bad a while back and i've had the part to replace it, i just havent!
Reply With Quote
  #2  
Old 11-20-2004
Member
 
Join Date: May 2004
Location: Fuquay Varina, NC
Posts: 3,048
hmm, should either be on your intake manifold or in the water neck where the tstat is, not positive on your engine. if you have a repair manual it will show it in there, and sometimes autozone has some vague component locations listed in their computers. good luck
Reply With Quote
  #3  
Old 11-28-2004
Diabolic's Avatar
Member
Thread Starter
 
Join Date: Sep 2004
Location: Rising Sun, MD
Posts: 1,542
Turned out not to be the sending unit. Was the thermostat. Got it fixed!
Reply With Quote
  #4  
Old 02-08-2008
luke87gt's Avatar
Member
 
Join Date: Sep 2005
Location: Bay Area, CA
Posts: 8
Does anyone have a diagram of where this sending unit is on a 96 2.3L?

I know one of them is for the ECT and the other is for the gauge. My gauge is dragging so I want to locate the correct one.

Thanks
Reply With Quote
  #5  
Old 02-08-2008
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
The temp gauge SU has a red/white wire. The ECT sensor has gray/red and gray wires. The Wiring Manual doesn't have a good diagram but it looks like the 2.3 gauge SU might be somewhere toward the back of the cylinder head on the driver side.
Reply With Quote
  #6  
Old 02-08-2008
TireIron's Avatar
Member
 
Join Date: Feb 2006
Location: Methuen, MA
Posts: 790
on the 94 and older it is mounted in the driverside of the block back near the firewall and just has a single push on wire that goes to it. It should be in the same place on your 96 I believe. I couldn't get to it from the top but it was easy to get to from underneath.
Reply With Quote
  #7  
Old 02-21-2008
mps01r6's Avatar
Member
 
Join Date: Sep 2007
Location: dallas
Posts: 84
the temp sending unit for the gague is on the drivers side of the motor on the block. change mine on my 95 2.3L about 2 weeks ago. it has a one wire connection and it is easier to get from the bottom of the truck
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bad temp sending unit? Bad thermo? __Arod__ 4.0L OHV & SOHC V6 Tech 2 12-03-2010 04:18 PM
TEMP. GUAGE SENDING UNIT kwhitmer83 General Technical & Electrical 7 11-13-2010 10:42 PM
5R55E Temp Sending Unit kawa General Ford Ranger Discussion 20 05-08-2010 12:35 PM
is this my oil sending unit? also, how do i take off my fan? Bigdank 4.0L OHV & SOHC V6 Tech 12 01-01-2008 06:03 PM
Oil pressure sending unit......where? KnightRider 2.9L & 3.0L V6 Tech 5 09-16-2005 09:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:45 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.