1990 2.9 please help. - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-04-2010
loki's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: Pittston
Posts: 11
1990 2.9 please help.

1990 2.9 v6 extended cab . Always smeels like antifreeze. Temp guage never even gets to the half way mark. Truck seems to run just fine and does not leak. But even after the short ride to work (2 Miles) I get out and smell antifreeze. . . . I tryed to check the oil after the truck was warm to see if I was getting antifreeze in the oil but the dipstick holder is rusted off and the stick does not go deep Enough to see anything on it. Oil pressor guage always shows within the normal range.


Please. Advise. I need this truck to stay alive.

Edit
The heater seems to work fine.

Last edited by loki; 03-04-2010 at 07:25 AM.
Reply With Quote
  #2  
Old 03-04-2010
loki's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: Pittston
Posts: 11
Cross Post

This is a cross post I put up on another forum,

PLEASE HELP

PLEASE PLEASE PLEASE
I don't know what to do.
PLEASE PLEASE PLEASE

Just got the truck not even two weeks ago, 1990 ford ranger extended cab 2.9L v6 4x4.

First the car I was driving before buying the truck was my dads and after I got the truck he gave it to my sister, so getting the car back is not going to happen.

That being said here's my story

OK so here's the deal got the truck feb 20th it had what I thot was a valve tick so I got some oil treatment from auto zone, Not the cheep stuff mind you. All seemed ok for the past few days but I was only driving the truck to and from work with is only 2 miles one way. All was city driving and under 30mph. So today after work I ran to the local mall (about 12 miles one way speed limit 45) and about half the way there the valve tick came back loader then before also seemed to have no power. Got to the mall checked oil and there seems to be none in the truck at all. Got a quart of oil did my shopping and drove home. Tick turned to a rumble that shacks the truck at idle. I thot WTF I must have an oil leak. Got home and pulled the dipstick, No oil. Looked around for over an hour could not find fresh oil leaking anyplace.
Jumped on the net and found someone talking about antifreeze getting into oil and killing engines. Then found a link that said it was a problem with the 2.9L v6 made before 1989. My truck is a 1990, the link said ford fixxed the trouble in 89.

Is it posable My truck has an 89 engine ? I checked the antifreeze reservoir as recomended on the one link I found and the antifreeze is not green it's more like a brown yucky looking goo.

Did I get lemoned ? What should I do ? I'm no mechanic but really need this truck, And I'm scared to drive it now. I used my whole income tax to buy the truck and have an 8 year old daughter that I need to pick up from school and tutoring, then there's also the fact that it's a 2 mile one way walk to work.

PLEASE PLEASE help . I have some tools and access to an indoor shop to work on it after work but have no idea what I should be looking for or how to fix it.

Once again PLEASE help Single dad with little cash in need of this truck in working order.


::EDIT::
Temp gauge hadly ever move's from cold. Heater works but does not seem to work very well. ( Thot That might be related so I edited to add it)
Reply With Quote
  #3  
Old 03-04-2010
pwrranger88's Avatar
Member
iTrader: (1)
 
Join Date: Dec 2008
Location: West Greenwich RI
Posts: 330
you most likley have a cracked head or a blown head gasket the change don't keep running the truck like it is or it will most likely cause perminent damage if it already hasn't. the easiest route to take is not to even bother wasting you time with fixing the current motor and call around to junk yards for a replacement motor.

Last edited by pwrranger88; 03-04-2010 at 08:00 PM.
Reply With Quote
  #4  
Old 03-04-2010
loki's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: Pittston
Posts: 11
Quote:
Originally Posted by pwrranger88 View Post
you most likley have a cracked head or a blown head gasket the change don't keep running the truck like it is or it will most likely cause perminent damage if it already hasn't. the easiest route to take is not to even bother wasting you time with fixing the current motor and call around to junk yards for a replacement motor.
OK what engines would just bolt right in, I ask just in case they have no 1990 2.9's
Reply With Quote
  #5  
Old 03-04-2010
pwrranger88's Avatar
Member
iTrader: (1)
 
Join Date: Dec 2008
Location: West Greenwich RI
Posts: 330
any 2.9 will bolt up if at all possible get an 89 and up cause thats the year they started using better heads. a "good" 2.9 shouldn't cost to much i recently bought one with 50,000 for $150
Reply With Quote
  #6  
Old 03-04-2010
loki's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: Pittston
Posts: 11
Been all over the net today trying to learn as much as I can about this head gasket trouble, and it seems to me that in most cases I find everyone is saying there cars/trucks are over heating. If it is a head gasket or cracked head why is my truck always running way cold? Also I'm not putting out any white smoke or any smoke at all for that matter.

Also has anyone used RxAuto Head Gasket Repair | Blown Head Gasket | Call 1-866-780-9042 or http://www.barsproducts.com/tech/1100_tech.pdf with any luck. At least for lets say a 6 month fix so I can save up some money to get things fixxed right.

While I can come up with the 150 for a junkyard engine I would have no clue as to how to install it and hear getting an engine installed would run me $500.00 to $800.00 plus hose's and clamps and getting the timing setup and weeks of down time.

As where the two above products only require drain and flush of oil and radiator, and the product.
Would the products last say till mid summer when work pic's up and I can comeup with the cash to get it fixxed right?

Last edited by loki; 03-04-2010 at 09:58 PM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
PLEASE PLEASE PLEASE.... annguyen1981 General Ford Ranger Discussion 13 12-05-2013 03:35 PM
1990 2.3l 2wd cat delete help glibby89 SOHC - 2.3L & 2.5L Lima Engines 10 05-06-2010 04:32 PM
1990 2.9L V6, Engine Trouble PLEASE HELP ! ! loki 2.9L & 3.0L V6 Tech 4 04-24-2010 04:36 PM
1990 Ranger code reader help mikemagooo General Ford Ranger Discussion 1 07-07-2008 12:04 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:32 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.