Vexing starting problem unless primed with gas. - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-07-2013
Member
Thread Starter
 
Join Date: Aug 2013
Location: Glenwood
Posts: 4
Vexing starting problem unless primed with gas.

Problem:
- The system will only start if primed first with with gas.
-After it starts and runs for a few minutes it will start again and again till cool, normally.
-There is about 58 pounds of fuel at the fuel rail.
-New fuel filter.
-All this started after changing out the water pump and clutch fan.
History:
2004 Ford Ranger with a 3L.
- Earlier this year it was starting to have some issues staying running. If I ran into a store for 5-10 minutes it sometimes had issues running unless I gave it a little extra gas out of the parking lot. Two foot driving. After I hit the main road it would work fine.
- Over heated due to small leak from radiator hose. But was started 3 or 4 times since then to get it home and in the garage. I also quickly added water to keep it cool till I got home.
- Changed out water pump, clutch fan and lower radiator hose.
- It has about 150k miles.
- No error codes or check engine lights.
- After changing out water pump I tried to start it, but it would only start with GREAT effort and sounded rough the couple of times I was able to get it started.
- Later I learned I could prime the engine with gas and it would start with little issue and often would continue to run if I pushed the gas peddle down a bit
.
- Of course I noticed other issues as I was rolling around and replaced the front shocks, and sway bar links.
- The spark plugs looked a sight so they have been replaced too. Noticed when checking for spark.
Not sure what else to do. Just hopping some kind soul out there has some idea of what is going on and can give me an idea of what to look for or do. My little truck has been very good to me and this is the first bit of trouble it has ever given me.

Thank you in advance.

Tim
Reply With Quote
  #2  
Old 08-11-2013
Member
Thread Starter
 
Join Date: Aug 2013
Location: Glenwood
Posts: 4
Maybe the ECU???

I've been thinking maybe its the ECU. Does anyone else have anymore ideas? I've seen reconditioned ECU's online for $200.
4L5AAKA, 788571F Remanufactured FORD TRUCK/VAN Electronic Control Module - ECM/ECU/PCM Computer : Amazon.com : Automotive 4L5AAKA, 788571F Remanufactured FORD TRUCK/VAN Electronic Control Module - ECM/ECU/PCM Computer : Amazon.com : Automotive
I just don't want to throw money at it if that is not the problem.
Reply With Quote
  #3  
Old 08-15-2013
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Have you done a fuel pressure test with the engine running?
Reply With Quote
  #4  
Old 08-15-2013
Member
Thread Starter
 
Join Date: Aug 2013
Location: Glenwood
Posts: 4
Fuel Presure

The pressure was just over 60 pounds when running.

Thank you for responding.
Reply With Quote
  #5  
Old 09-09-2013
Member
Thread Starter
 
Join Date: Aug 2013
Location: Glenwood
Posts: 4
I thought I would post the answer to my problem. Maybe it will help someone else. I swallowed my pride and took it into the dealer. The electronic coolant temperature sensor was the problem. It was reading 200F some degrees. This was a new sensor I had replaced, due to breaking it when working on the water pump. Well, I have an answer and out $280, but I have it running.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
No idle unless i rev it famousranger13 4.0L OHV & SOHC V6 Tech 6 03-06-2010 12:47 AM
We dont fix Fords at our shop. Unless is's one of these!! lol effexfour Snapshots 22 01-10-2010 11:11 AM
Unless you have 2 minutes of spare time. Dromlace Wheels & Tires Semi-Tech 52 10-13-2008 04:39 PM
great video... wouldn't believe it unless you see it 94greenmachine General Ford Ranger Discussion 4 04-21-2007 04:15 AM
Bumper primed... TBarCYa General Ford Ranger Discussion 10 03-25-2005 08:59 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.