IAC Hell - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-31-2010
DimeWylde's Avatar
Member
Thread Starter
 
Join Date: Dec 2009
Location: Louisville, Kentucky
Posts: 55
IAC Hell

My IAC (Idle Air Control) was acting up by letting the engine idle at 2K and it got up to 3K in between shifts. I took it off, cleaned it the best I possibly could with carb cleaner and it did nothing. I went to the junkyard and pulled one off of an explorer and still had the same problem. This brought me thinking that it wasn't the problem until I just disconnected the plug off the IAC. As soon as I disconnect it, its drops down the a perfect 700 rpm and does perfect. I plug it back in, hit the throttle once, and she stands at 2K again. So I have been driving with it disconnected with the downfall of having to keep it running when its cold by pushing the gas pedal a little bit. Does anyone ever deal with the same problems? It acts up when its warm, cold, all the time.
Reply With Quote
  #2  
Old 05-31-2010
scratchbgone's Avatar
Member
 
Join Date: Apr 2010
Location: JACKSONVILLE FL.
Posts: 10
been having same issue got one from advance lasted a month started causing a moaning sound put the clean factory back on stop the moaning but idles high during driving like 1500 rpm I need to just buy a new motorcraft one ps junk yard you never know its a big problem with fords could been bad too
Reply With Quote
  #3  
Old 05-31-2010
brianjwilson's Avatar
Member
 
Join Date: Nov 2006
Location: Hillsboro, Oregon
Posts: 3,650
I replaced the IAC on my ranger and explorer with replacements from Napa and never had a problem. Cleaning was a short term solution that ended up making them worse.
Reply With Quote
  #4  
Old 05-31-2010
Alex98's Avatar
Member
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
it might not be the aic at all, the ohv motors had a problem with the upper intake gasket which caused a similar problem.
Reply With Quote
  #5  
Old 05-31-2010
brianjwilson's Avatar
Member
 
Join Date: Nov 2006
Location: Hillsboro, Oregon
Posts: 3,650
The intake manifold gaskets had issues, but when I had bad intake gaskets it never messed with the idle like that.
Reply With Quote
  #6  
Old 05-31-2010
korey89's Avatar
Member
iTrader: (2)
 
Join Date: Mar 2008
Location: South, FL
Posts: 4,672
Why wouldn't you buy a new one by now?...
Reply With Quote
  #7  
Old 05-31-2010
Alex98's Avatar
Member
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
well mine wouldnt do that specifically but it would be kinda like that tho.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
a new iac valve, and now a whine???? erock 4.0L OHV & SOHC V6 Tech 5 12-17-2006 09:19 PM
Iac RockysFord 4.0L OHV & SOHC V6 Tech 14 09-01-2006 09:43 AM
IAC Valve question bryanjints 4.0L OHV & SOHC V6 Tech 5 07-10-2006 06:12 PM
IAC Valve DangaRanger99 General Ford Ranger Discussion 19 06-26-2006 10:25 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:10 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.