po171 and po174 - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-15-2009
strakill's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
po171 and po174

So my truck threw me a po174 code, lean bank two. I found a hole in the pcv elbow, so I replaced. No more rough idle. Well i erased the code and the cel came back on. po171 and 174. I have zero problems with the motor. It operates great. i double checked and no leakes. The only thing Im getting is a loud ping wich sounds like its coming from my cats ( as its heating up and then when it cools down).The code reader shows I have a closed fuel system and all o2 sensors are working. Im stumped Please help
Reply With Quote
  #2  
Old 03-15-2009
element4all's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: Forest Hill, Maryland
Posts: 570
check my thread man, discussion is going on there now with my truck too
Reply With Quote
  #3  
Old 03-18-2009
Alex98's Avatar
Member
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
Those two codes are most likely from a minor vacuum leak on or near the intake plenum, especially if that plenum is made from plastic. Had to replace a gasket on my high mileage '98, and it cleared the codes. Those codes come when the computer cannot adjust the air/fuel mixture correctly. They occur more frequently on high mileage vehicles and, as said, the ones with plastic intake plenums. Hope it helps.
Reply With Quote
  #4  
Old 03-18-2009
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
I had a leaky vac hose behind the engine. Fixed it, no more codes. Also, the crankcase vent to the intake tube would do it too.
Reply With Quote
  #5  
Old 03-18-2009
buckgnarly's Avatar
Member
iTrader: (11)
 
Join Date: Jan 2005
Location: West Topsham, VT
Posts: 1,709
Ping is more than likely the contracting and expanding of the metal in your exhaust system.
Reply With Quote
  #6  
Old 03-19-2009
strakill's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
well I found a hole in the pcv hose elbow and replaced it. I cleared the codes are they stay away, but I still get the annoying ping and I think its coming from the exaust. It wasnt there before this problem so now Im confused. Its a really loud ping, could this mean the end to one of my cats?
Reply With Quote
  #7  
Old 03-22-2009
strakill's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
Bump. Im lost.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
99 4wd 3.0 getting the dreaded po171 po174 codes. jerseyman32 2.9L & 3.0L V6 Tech 5 02-12-2015 06:33 PM
Fix for Check Engine light codes: p0401, po171 and po174 TheBearJeweler General Ford Ranger Discussion 66 02-05-2013 09:54 AM
OBD Codes PO171 & PO174 Runarenis General Technical & Electrical 13 07-13-2011 09:13 PM
Fault codes PO171 PO174 dochawken 2.9L & 3.0L V6 Tech 2 09-16-2010 05:09 PM
po171 and 174 codes ranger02 4.0L OHV & SOHC V6 Tech 14 05-08-2009 07:13 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.