99 4wd 3.0 getting the dreaded po171 po174 codes. - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-06-2014
Member
Thread Starter
 
Join Date: Jul 2014
Location: Aberdeen,maryland
Posts: 22
99 4wd 3.0 getting the dreaded po171 po174 codes.

Hello everyone, failed my emissions and got the following codes po171 po174.. I have tried installing a new pcv valve, maf sensor,unplugged the iac and it slowed the rpm down some but didn't cut out,searched for air and vacuum leaks with carb cleaner no leaks found, at my wits end, check engine light still on and codes are still reading the same.God bless
Reply With Quote
  #2  
Old 08-07-2014
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,609
Check fuel pressure, should be 60-65psi on '99
Low fuel pressure cause lean codes.

If you haven't changed it recently, change fuel filter, $10-$15, dirty filter can lower flow but pressure stays high.

Also DPFE sensor usually fails after 60,000 miles, $35-$45 for non-Ford DPFE sensors, replace that if it hasn't been replaced before, make sure it's hoses are good.
Incorrect DPFE sensor data to computer will cause too much exhaust gas to be sent to the intake via EGR valve, this causes lean codes 171/174


And often overlooked is the "ported" vacuum leak.
MAF sensor reports the air flow/volume to the computer, computer bases air/fuel mix of 14:1 on this data, so ALL the air going into the engine must pass thru the MAF sensor.
On some engines the MAF sensor is near the air cleaner and connected to the intake manifold by a long hard plastic air plenum/tube.
If that air plenum cracks or has a leak somewhere, that is a "ported" vacuum leak.
So all the air coming in to the intake is not passing thru the MAF sensor, so MAF sensor is under-reporting the amount of air flow.
If you have an air plenum, remove it and inspect it closely.

Last edited by RonD; 08-07-2014 at 12:03 PM.
Reply With Quote
  #3  
Old 08-08-2014
Member
iTrader: (2)
 
Join Date: May 2014
Location: Lake Mary, Florida
Posts: 349
RonD, whenever I read your responses, I learn! I had to go off and Google what a DPFE sensor was (Differential Pressure Feedback EGR). This sensor, as I read on it, allows the EGR to allow hot exhaust gases back into the intake to be reburned, allowing for "cleaner" exhaust. The DPFE gets pressurized by the exhaust gas, and informs the ECU. The ECU tells the EGR actuator to open the valve and allow exhaust through tothe intake to be burned.
So now I can see how this would lean out the mixture if it's not functioning properly.
Attached Thumbnails
99 4wd 3.0 getting the dreaded po171 po174 codes.-fordegrsystem.jpg  
Reply With Quote
  #4  
Old 08-08-2014
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,609
Thanks

Yes, the DPFE sensor has one hose connected near the EGR valve and one hose connected farther away from the EGR valve on the exhaust system, the pressure difference between the two hoses 'tells' the computer IF the EGR valve is open and if open, how far it is open, computer then adjusts EGR flow based on that info.

Hot exhaust gases "cool" the cylinder temperatures, odd as that sounds, lol.
EGR system is only used when engine is under load because that is when cylinder temps start to rise.
High cylinder temps cause high NOx emissions, so EGR system was added to reduce NOx.
By product of lower cylinder temps is less or no "pinging/knocking", which is caused by high cylinder temps pre-igniting air/fuel mix.
If you start to get pinging when accelerating or going uphill then EGR system probably needs some attention, or you got some very low octane fuel, lol.

Last edited by RonD; 08-08-2014 at 10:55 AM.
Reply With Quote
  #5  
Old 08-08-2014
Member
Thread Starter
 
Join Date: Jul 2014
Location: Aberdeen,maryland
Posts: 22
Ron d, your a huge help,thanks again!
Reply With Quote
  #6  
Old 02-12-2015
Member
 
Join Date: Dec 2006
Location: Ohio
Posts: 12
Did that sensor take care of your problem? Researching the same codes and possible causes. My truck runs fine, I have already changed out the upper and lower intake gaskets last spring as they had gone bad and also changed out the O-2 sensors at that time. I know I have a bad filler tube on my gas tank that is pretty rusty and crusty and may have sprung a leak so I am replacing it as well. May go ahead and order the DPFE sensor and hoses since they are original to the truck, checked pcv and hose, they are fine. My lite just popped on a couple of days ago and I pulled the codes with my scanner, probably only the 3rd time my truck has flashed check engine in the 17 years I have owned it with just over 95000 miles on it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fix for Check Engine light codes: p0401, po171 and po174 TheBearJeweler General Ford Ranger Discussion 66 02-05-2013 09:54 AM
OBD Codes PO171 & PO174 Runarenis General Technical & Electrical 13 07-13-2011 09:13 PM
Fault codes PO171 PO174 dochawken 2.9L & 3.0L V6 Tech 2 09-16-2010 05:09 PM
po171 and 174 codes ranger02 4.0L OHV & SOHC V6 Tech 14 05-08-2009 07:13 AM
po171 and po174 strakill 4.0L OHV & SOHC V6 Tech 6 03-22-2009 12:42 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.