truck starting weird - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-10-2012
orange-ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: Cloverdale
Posts: 77
truck starting weird

hey guys i have a 2000 ford ranger with a 4.ol. about a month ago it started having starting problems

what it is doing. when i turn key it turns over and fires no problem but quickly drops and almost stalls then runs ruff for a few seconds but after that once engine is warm it has no problems at all. advice would be great.
i changed fuel filter last week didnt change, plugs done within the year?

thanks a lot
Reply With Quote
  #2  
Old 01-10-2012
orange-ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: Cloverdale
Posts: 77
if anyone has any advice it will help really want to keep this truck runnin strong
Reply With Quote
  #3  
Old 01-10-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
clean sensors and filters and have scanned at local store for codes

fuel Filter was a good start, but clean away and/or replace: IAC, MAF, TB, intake box and tube, replace/clean air filter, plugs, wires, etc.

As for running strong: do a fully synthetic oil change with a super high quality filter for 1 or two changes (5K miles with syn), replace pumpkin fluid (judging by the avatar, replace both pumpkin fluids), fully flush coolant system, old coolant tends to chemically changea nd quickly becomes corrosive and rusts the guts of a coolant system, fully synthetic tranny fluid change (dont recommend flushing but thats your choice) with new filter. Plugs and wires are always a nice thing to change. new air filter (better breathing, better running).
Reply With Quote
  #4  
Old 01-10-2012
morris's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
Yea, Check the codes and post here.
Reply With Quote
  #5  
Old 01-10-2012
orange-ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: Cloverdale
Posts: 77
checked codes everything is all good. as for fluids tranny and coolant done in august. oil changed 2 weeks ago. all advice is helpful. all obd sensors done in spring same time as plugs
Reply With Quote
  #6  
Old 01-10-2012
orange-ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: Cloverdale
Posts: 77
Quote:
Originally Posted by rangerrunner11 View Post
clean sensors and filters and have scanned at local store for codes

fuel Filter was a good start, but clean away and/or replace: IAC, MAF, TB, intake box and tube, replace/clean air filter, plugs, wires, etc.

).
IAC MAF TB? what are they and what should i clean with?
Reply With Quote
  #7  
Old 01-10-2012
morris's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
MAF is your mass air flow sensor. TB is throttle body. IAC idk...
Reply With Quote
  #8  
Old 01-10-2012
orange-ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: Cloverdale
Posts: 77
thanks. also does anyone have advice for getting front diff cover off. crossmember seems to be in the way?
Reply With Quote
  #9  
Old 01-10-2012
Kris03's Avatar
Member
 
Join Date: Jun 2011
Location: glastonbury, ct
Posts: 1,236
Wirelessly posted

You have to suck it via pump through the fill screw. Otherwise u have to drop front axle.
IAC is idle air control valve. Check that first and coolant temperature sensor
Reply With Quote
  #10  
Old 01-10-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
IAC is idle air control valve, on top of Tb (throttle body). has two screws on either side. has a paper diaphragm under it, dont rip/tear/mangle it. but clean it really good, unplug it, flip it over, fill with carb cleaner and let soak over night
Reply With Quote
  #11  
Old 01-10-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
I also suggest seafoaming it. one can wotn foul the plugs like folks say. have a bud sit in the drivers seat and hold the rpms at 2K and then follow normal seafoam procedure. helps an *** load
Reply With Quote
  #12  
Old 01-10-2012
orange-ranger's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: Cloverdale
Posts: 77
great thanks guys ill see what i can make work
Reply With Quote
  #13  
Old 03-06-2012
Member
 
Join Date: Jan 2012
Location: Cheboygan, mi
Posts: 11
any luck?
Reply With Quote
  #14  
Old 03-06-2012
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
I can 100% guarantee it was his IAC or his MAF. Its a very common problem with Rangers.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Weird Electrical Issues Related to Starting culinandy 4.0L OHV & SOHC V6 Tech 3 10-03-2013 07:51 PM
weird clunking i hear when my truck hits a bump kingwoodranger Suspension Tech 4 12-30-2009 01:37 AM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 11:33 AM
Weird idle problem when putting truck in neutral coming to stops. Jeremy102579 2.9L & 3.0L V6 Tech 13 03-25-2007 10:26 AM
My Truck Is Weird BaggedEdge Suspension Tech 4 05-09-2005 02:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.