valve noise - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-26-2016
Member
Thread Starter
 
Join Date: Jan 2016
Location: Conway, AR.
Posts: 2
valve noise

I just finished putting a new timing set in my 03 ranger 4.0 (the tensioner failed on the rear chain w/o damage) now I have what seems to be valve train noise, has anyone had the same problem after replacing the timing sets on this motor? I know that these engines have problems with lubrication and that I might possibly have to replace the lifters and pushrods. By the way the noise is at all RPM ranges. Thanks in advance for any knowledge on this.
Reply With Quote
  #2  
Old 01-26-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,615
2003 Ranger would have the 4.0l SOHC engine, 2000 and older Ranger had the 4.0l OHV engine

No lifters or push rods on SOHC or DOHC engines, OHV engines have those.

Never heard of any issue with oil flow in the SOHC engine, or the OHV for that matter.
The timing chain issue was a design issue, not an oil issue.

So you pulled out the engine and replaced all the chains, cassettes and tensioners.

Not sure what it could be, I guess you will need to pull valve cover(s) again and see if anything is loose.
Reply With Quote
  #3  
Old 01-26-2016
Member
Thread Starter
 
Join Date: Jan 2016
Location: Conway, AR.
Posts: 2
Quote:
Originally Posted by RonD View Post
2003 Ranger would have the 4.0l SOHC engine, 2000 and older Ranger had the 4.0l OHV engine

No lifters or push rods on SOHC or DOHC engines, OHV engines have those.

Never heard of any issue with oil flow in the SOHC engine, or the OHV for that matter.
The timing chain issue was a design issue, not an oil issue.

So you pulled out the engine and replaced all the chains, cassettes and tensioners.

Not sure what it could be, I guess you will need to pull valve cover(s) again and see if anything is loose.
I fat fingered the keyboard it's an 02 not 03 but it sounds like it doesn't matter. So I guess that I have to look and see if there is something loose like you said thanks for the info RonD.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
4.0 OHV valve noise or main bearing noise blair683 4.0L OHV & SOHC V6 Tech 4 07-09-2015 09:40 PM
4.0 valve train noise swickwake 4.0L OHV & SOHC V6 Tech 15 05-12-2013 11:47 AM
Cold start valve noise. LastStarfighter General Ford Ranger Discussion 22 02-25-2012 08:43 PM
valve noise question benrwise 4.0L OHV & SOHC V6 Tech 4 07-21-2010 06:36 PM
For Sale: ranger 4.0 headgasket valve cover gasket header gasket & viton valve stem seals $10+ talkforparts Interior, Exterior, Electrical, & Misc. 0 07-20-2010 02:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.