no reverse?!?!? - Ranger-Forums - The Ultimate Ford Ranger Resource

Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

no reverse?!?!?

  #1  
Old 12-11-2006
mcerwing's Avatar
Member
Thread Starter
Join Date: May 2005
Location: hesperia, ca
Posts: 171
no reverse?!?!?

this problem started a few days ago. every time i shift into reverse to go, i have to hold the stick to make sure it doesn't pop out. i have the clutch fluid full. also, i don't know if this is a related matter or not, but my transmission makes a wierd noise... kinda like there's something in it. but i drained the tranny fluid a long time ago and the noise didn't stop.

any help?
 
  #2  
Old 12-11-2006
Join Date: Nov 2006
Location: Charlottesville, VA
Posts: 239
Did you put new fluid back in?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dogfish246
General Ford Ranger Discussion
0
10-10-2014 01:33 PM
Grande1972
General Technical & Electrical
0
03-10-2013 09:36 PM
gw2
Drivetrain Tech
2
10-08-2012 08:34 PM
SanityAside
General Technical & Electrical
19
01-15-2006 01:25 AM
SonicBlueFIB
General Technical & Electrical
15
09-27-2005 12:49 PM


Thread Tools
Search this Thread
Quick Reply: no reverse?!?!?


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.