Vibration letting off gas? - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-23-2011
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Vibration letting off gas?

I have a vibration under me or in the rear end. It's happening when I'm at highway speed and let off the gas. It only vibrates for a second or so after I let off and gets worse with speed. Anybody had this problem? Maybe u-joints or slip joint needs greasing?

I just replaced my front driveshaft, it was shot, and it's still there. Checked the rear driveshaft and there is very little play in it. Had a friend tell me it could be my gears, backlash or something.

Thanks.

Last edited by seed60; 02-23-2011 at 08:36 PM.
Reply With Quote
  #2  
Old 02-24-2011
Member
 
Join Date: Feb 2011
Location: Washington, DC
Posts: 2
It can be two things I can think of

1. A bent Axel

Or

2. A flat spot in the drive shaft
Reply With Quote
  #3  
Old 02-24-2011
fourliter dan's Avatar
Member
 
Join Date: Dec 2007
Location: Lebanon, OR
Posts: 2,229
Wow no.... Sounds more like your diff is hurting. Pull ur drive line and check your in and out play and up and down play on your pinion. Sounds like a expo axle in the making.
Reply With Quote
  #4  
Old 02-24-2011
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Quote:
Originally Posted by fourliter dan View Post
Wow no.... Sounds more like your diff is hurting. Pull ur drive line and check your in and out play and up and down play on your pinion. Sounds like a expo axle in the making.
I hope that's not the case. I just swapped in an expo axle last year.

I'll have to check that. I didn't notice a whole lot of movement when I was checking the driveshaft for play.
Reply With Quote
  #5  
Old 02-24-2011
Member
 
Join Date: Feb 2011
Location: Clinton, SC
Posts: 49
Quote:
Originally Posted by seed60 View Post
I have a vibration under me or in the rear end. It's happening when I'm at highway speed and let off the gas. It only vibrates for a second or so after I let off and gets worse with speed. Anybody had this problem? Maybe u-joints or slip joint needs greasing?

I just replaced my front driveshaft, it was shot, and it's still there. Checked the rear driveshaft and there is very little play in it. Had a friend tell me it could be my gears, backlash or something.

Thanks.
Could be trans, yoke, u-joint, slip joint, pinion bearing, etc, how does it feel at a steady 45 mph on smooth road?
Reply With Quote
  #6  
Old 03-14-2011
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Quote:
Could be trans, yoke, u-joint, slip joint, pinion bearing, etc, how does it feel at a steady 45 mph on smooth road?
It's good as long as I'm on the gas.


I think I've found the problem. Got the truck up on stands today to fix the ebrake and the ujoint is busted. Couldn't tell it with the tires on the ground while trying to move the driveshaft but once I got it up you could you see the slack in it.

Thanks.
Reply With Quote
  #7  
Old 03-14-2011
RazorsEDGE's Avatar
There's no lifeguard in the gene pool
iTrader: (4)
 
Join Date: Aug 2006
Location: New Mexico
Posts: 7,501
Yeah I'd definitely start with the ujoints. They're cheap and fairly easy to replace, and if they're bad they can cause vibrations just like you described.
Reply With Quote
  #8  
Old 03-16-2011
immortal_vision's Avatar
Member
 
Join Date: Dec 2009
Location: C
Posts: 612
any updates on this?? im having the exact same problem right now but gets worst when i apply the gas on the highway
Reply With Quote
  #9  
Old 03-16-2011
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Quote:
Originally Posted by immortal_vision View Post
any updates on this?? im having the exact same problem right now but gets worst when i apply the gas on the highway
Haven't got it fixed yet. Still waiting on the u-joints to get here. Nobody around here sold Spicers so I had to order them.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Noise in Four-Wheel Drive when letting off the gas rangercutie93 4.0L OHV & SOHC V6 Tech 1 02-04-2015 06:23 PM
Wobble when letting off gas FlounderFX4 Suspension Tech 7 06-03-2010 12:57 PM
wierd thump when letting off the gas cboveda Drivetrain Tech 15 04-05-2009 02:44 AM
Misses letting off of throttle ckbwv SOHC - 2.3L & 2.5L Lima Engines 0 03-30-2008 07:40 PM
Squeaks when letting off the gas truckasaurus Drivetrain Tech 4 10-24-2007 12:30 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:03 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.