cold start rough idle - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-28-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: king george virginia
Posts: 137
cold start rough idle

i have 93 3.0liter 4x4 auto and only on cold starts it acts wierd...when i 1st start it it runs fine for a few seconds then spits and sputters around for 5-15 seconds just depends on the day and then it levels itself out i have recently done plugs wires cap rotor coil fuel filter and cleaned the MAF and thrttle body any suggestions on wat it could be...btw i did all this to try and fixthis issue as it has helped but didnt fix it
Reply With Quote
  #2  
Old 09-28-2010
30coupe's Avatar
Member
 
Join Date: Jan 2008
Location: Manly, IA
Posts: 54
Are you using ethanol blend? That will cause it for me.
Reply With Quote
  #3  
Old 09-30-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: king george virginia
Posts: 137
yes everything where i live is supposdly 10% blended ethanol but no other vehicle ive ever owend has had a problem with the fuel and this has been an issue since i got it about 8 months ago
Reply With Quote
  #4  
Old 09-30-2010
Needforspeed3685's Avatar
Member
 
Join Date: Aug 2005
Location: Lowell, AR
Posts: 1,836
That's funny....my truck has been doing the same lately. I use Shell gas religiously, which is 10% ethanol blend. I changed plugs, wires, oil (routine), tranny fluid and filter, fuel filter, and coil packs to no avail. Hmmmmmmmm.....
Reply With Quote
  #5  
Old 09-30-2010
hozII's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: athens, Al
Posts: 2,245
May wanna try cleaning your throttle body, AIC, and MAF....prob wouldnt hurt to do the fuel filter and lil things like that, that haven't been done in a long time...lol
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
rough idle, stalls out on cold crank theboling 2.9L & 3.0L V6 Tech 7 01-18-2011 06:44 PM
cold start rough idle rpwillix 2.9L & 3.0L V6 Tech 3 10-16-2010 08:09 PM
Rough Start (cold) ChaosFromAbove 2.9L & 3.0L V6 Tech 17 06-15-2010 05:48 AM
rough idle at cold temp it seems..... hartmen SOHC - 2.3L & 2.5L Lima Engines 6 09-30-2008 10:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.