Transmission sometimes not engaging... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-22-2014
Member
Thread Starter
 
Join Date: Sep 2014
Location: Boulder, CO
Posts: 1
Transmission sometimes not engaging...

Hello!

I recently bought a 1993 Ranger V6 4.0L 4x4.

I did a transmission flush, changing the filter and fluid. All seemed to work out well with the fluid change.

Soon after I drove the truck towing about 1,100 lbs for just over 2,000 miles round trip. There was never an issue with the transmission while towing.

The day we removed the trailer and truck bed load the transmission started to act funny.

When the truck starts in the morning I am able to drive it for a moment and then first gear seems to slip out of gear. I then stop and run the fear shifter back and forth through all the gears. Then eventually it pops into gear and I'm on my way. It only happens once when the truck is first started for the day. After that it shifts perfectly.

Fluid level is good.

Any thoughts out there? I'm a rank amateur mechanic and transmissions are a bit above my pay grade. 😛
Reply With Quote
  #2  
Old 09-23-2014
loc's Avatar
loc loc is offline
Member
 
Join Date: Feb 2014
Location: roopville,ga
Posts: 28
Bands needs adjusting

Hey sounds like lots of miles ? You maybe able to salvage by adjusting your bands .
This is not an easy job . loosing the lock nut & turn till the adjuster bottoms out with your finger tips . then turn one complete turn back out & lock the jam nut .
If this don't do it you'll need an overhaul. By the way I graduated Rocksprings area tech back in 1969 in auto tech.
Reply With Quote
  #3  
Old 11-25-2014
Member
 
Join Date: Nov 2014
Location: Central, TX
Posts: 49
I had a similar problem. Occasionally I would have to go from D back to N and back to D to get D to engage when it was cold outside. It turned out that it was the digital transmission range sensor which is also known as the neutral safety switch.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
4x4 not engaging, and no "4x4" light rideac1 Drivetrain Tech 28 10-11-2017 07:23 PM
Automatic Transmission problem (slip, not engaging) when Hot rdelp68 Drivetrain Tech 1 08-23-2011 08:48 PM
4WD not engaging hellsranger Drivetrain Tech 4 10-15-2010 10:06 AM
4x4 not engaging samacdon Drivetrain Tech 11 02-23-2010 02:10 PM
4x4 not engaging..any suggestions? GSU4x4 Drivetrain Tech 5 01-28-2007 06:23 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.