AC Problems - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-27-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: West Columbia
Posts: 3
Icon7 AC Problems

Ok guys I need some help, my compressor is working but my truck is not blowing out air at all. I hear it working but no air is coming out of the vents or defroster. I thought it was my blend door but I checked it out and it was fine. Not sure if it is my control head or what. Any suggestions would be great!
Reply With Quote
  #2  
Old 06-27-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by fordchick View Post
Ok guys I need some help, my compressor is working but my truck is not blowing out air at all. I hear it working but no air is coming out of the vents or defroster. I thought it was my blend door but I checked it out and it was fine. Not sure if it is my control head or what. Any suggestions would be great!
Would help to know model and year of your truck. Have you check all fuses both in dash and under hood? Can you hear the fan motor running?
Reply With Quote
  #3  
Old 06-28-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: West Columbia
Posts: 3
sorry 2007 ford ranger, yes the fan is running, everything is working it is just not blowing out.
Reply With Quote
  #4  
Old 06-28-2012
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by fordchick View Post
sorry 2007 ford ranger, yes the fan is running, everything is working it is just not blowing out.
I believe the system will default to the defrost/floor outlets if you lose vacuum. If the fan motor is working you should have some air flow through those outlets. Are you sure the fan motor is working and if so through all speeds?
Reply With Quote
  #5  
Old 06-29-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: West Columbia
Posts: 3
everything is working, all speeds, the fan, all the actuators but the air is just not coming out anywhere
Reply With Quote
  #6  
Old 06-29-2012
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Only way that is possible is if the inlet duct is clogged, or the fan is really dirty/broken.

Pull the fan and check it.
Reply With Quote
  #7  
Old 07-04-2012
twinair's Avatar
Member
iTrader: (3)
 
Join Date: Apr 2011
Location: Nokesville, VA
Posts: 76
Are the vent dampers closed?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 07:35 AM
Clutch problems...possibly?!?!? Help?? ZetaOmegaRanger 2.9L & 3.0L V6 Tech 2 01-04-2008 02:47 AM
Door dinger mod... now problems with blinkers? Zero General Technical & Electrical 4 09-28-2004 11:35 AM
Amp problems Skyjacker_44 Audio & Video Tech 3 08-31-2004 09:52 AM
Driver's side seat belt problems... 98blackranger Interior Semi-Tech 6 06-24-2004 02:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.