Battery Light Question - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-03-2008
Member
Thread Starter
 
Join Date: Sep 2007
Location: MI
Posts: 25
Battery Light Question

I just changed my t-stat and hoses and went for a test ride, when half way through the battery light went on. I checked it with a meter and the battery is showing about 12.5v (not running) and 14.4v running (even if I rev the engine).

Any idea on why the light would be on if the regulator/ alt./ and battery seem to be ok??
Reply With Quote
  #2  
Old 01-03-2008
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Check all the alt connections making sure they're fully plugged in and or tight. Double check any other connections you may have unplugged replacing the thermostat.
Reply With Quote
  #3  
Old 01-03-2008
Member
Thread Starter
 
Join Date: Sep 2007
Location: MI
Posts: 25
Yeah, I did that and everything looks good. I did charge the battery and the light is now off. I guess I'll drive it to see if it drains again, or just get the battery tested to see if it's that or the alt...probably the battery since it's an old Optima I stole out of my drag car.
Reply With Quote
  #4  
Old 01-04-2008
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
When it's cold out, usually happens after left out overnight, the battery light will blink. The odd time it'll come on for a bit, but go away after I restart the truck. It used to do it more a couple years back.
Chances are you're battery might be going out. I haven't replaced the battery in mine and I'm not sure if the previous owner did. I've had it for 4 years now.
Reply With Quote
  #5  
Old 01-04-2008
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
here is a little suggestion.......when i changed my t-stat i got the same light and also metered the battery just like you did.....come to find out, i didn't re-install the drive belt...check that...
Reply With Quote
  #6  
Old 01-04-2008
Member
Thread Starter
 
Join Date: Sep 2007
Location: MI
Posts: 25
Never pulled the belt....
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Battery light question dadof2 General Technical & Electrical 8 12-06-2010 03:39 PM
1996 Battery light coming on, yet battery and alternator work' SariahLeah SOHC - 2.3L & 2.5L Lima Engines 2 06-04-2010 04:16 PM
battery light ABS light dim light RangerSkippyRoo General Technical & Electrical 3 05-25-2009 11:25 AM
NOT a Ranger Light Question, but still a Ford Light Question buggman General Technical & Electrical 1 11-19-2008 12:00 PM
running battery down, battery discharge from playing an amp'd system onebluemcm Audio & Video Tech 12 04-13-2007 04:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.