First time on, need urgent electrical help - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-31-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Connersville IN
Posts: 5
First time on, need urgent electrical help

We just upgraded the the stereo in my son's 2000 Ranger. We installed an amp and an aftermarket stereo. On the first pass, it was just to install the amp. During the pre install test using the factory stereo, one of the speaker wire positives grounded accidentally. The caused the following or appears to have caused the following issues: 1) The positive wire from the fuse box to the factory plug in has lost continuity. 2) The battery positive constant to the factory plug has lost power. 3) The heater and the AC position controls have stopped fuctioning. 4) The blower only blows high. 5) The AC is stuck in on position. 6) The left front headlamp low beam quit working (tried new bulb)

Is there a common point/link that could have caused these issues????? They were all fine prior to the grounding issue. I think I've blwon a relay or something that these are linked to....Any Ideas? (our Haynes Manual is no help)
Reply With Quote
  #2  
Old 07-31-2007
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
unhook the battery.

check all fuses/relays.

something is loose or still grounding out.

that is what i would check.
Reply With Quote
  #3  
Old 07-31-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Connersville IN
Posts: 5
We have checked all the fuses in the fuse box and the master power distribution box. We replaced the blower motor relay and the AC relay with no changes.....
Reply With Quote
  #4  
Old 07-31-2007
Marcaronio's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Spring Hill, FL
Posts: 560
So you only have added the amp so far? Where are your power, remote, and speaker wires or rca wires connected to for the amp?
Reply With Quote
  #5  
Old 07-31-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Connersville IN
Posts: 5
We wired around the bad positives from the fuse box for the main power and the 12 volt power outlet for the 12 volt constant power. The amp has a 50 amp in line fuse from the battery and we are using the power antanae for the amp on off function. The speakers are routed back through the original wiring harness from under the dash.
Reply With Quote
  #6  
Old 07-31-2007
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
Can you unplug the amp? but leave everything still tapped in the wires?

If so have you tried this?
Maybe you have something tapped that should not be.
Reply With Quote
  #7  
Old 07-31-2007
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
Does the cigarette lighter socket have power?

PM me an e-mail address and I will send you pages from the wiring book (acrobat).

Last edited by Earl43P; 07-31-2007 at 09:47 AM.
Reply With Quote
  #8  
Old 07-31-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Connersville IN
Posts: 5
The Cigarette lighter has power.

[email protected]

Thank you.
Reply With Quote
  #9  
Old 07-31-2007
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
e-mail sent.

Hope it helps. I'd pull the fuse for each affected system and verify there is power to the fuse in the junction box (radio, blower, AC).

Clean up the grounds on the fenderwells.

Let me know if you need individual system's pages.

Last edited by Earl43P; 07-31-2007 at 02:20 PM.
Reply With Quote
  #10  
Old 07-31-2007
2003stealthedge's Avatar
Member
 
Join Date: May 2005
Location: The ILL State
Posts: 1,297
if you grounded a speaker nothing would happen but your radio not get power and possibly blow a fuse. What other wires did you exactly hook up for power (besides the main amp power)? Seems like you hooked up something for power at the wrong wire. Disconnect everything and start checkin fuses again
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help. Urgent. Michaelbowers98 SOHC - 2.3L & 2.5L Lima Engines 12 04-18-2015 07:49 PM
Urgent!! Need 2WD AT help. seismicdrift Drivetrain Tech 3 01-20-2011 09:13 AM
Tranny Leaking - Need Urgent Help PharmRanger4x4 Drivetrain Tech 11 09-07-2009 07:50 AM
******URGENT HELP NEEDED***TRUCK TORN APART****NEED HELP****** Dangerranger01 Exterior Semi-Tech 34 07-28-2009 01:52 AM
Urgent! Need Help ion lift Kit Pixels2000Ranger General Ford Ranger Discussion 21 07-24-2007 06:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:07 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.